summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFco Javier Felix <ffelix@inode64.com>2023-09-11 13:22:23 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-14 21:22:37 +0300
commit2e5adc97c5d0031589af4ac241d110cbcb310f1a (patch)
tree0a3f02ecd9f243c63d78e9d6dd94e80977707392 /net-misc
parentapp-misc/regex-markup: update EAPI 6 -> 8 (diff)
downloadgentoo-2e5adc97c5d0031589af4ac241d110cbcb310f1a.tar.gz
gentoo-2e5adc97c5d0031589af4ac241d110cbcb310f1a.tar.bz2
gentoo-2e5adc97c5d0031589af4ac241d110cbcb310f1a.zip
net-misc/anydesk: bump version 6.3.0
Signed-off-by: Fco Javier Felix <ffelix@inode64.com> Closes: https://github.com/gentoo/gentoo/pull/32722 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/anydesk/Manifest1
-rw-r--r--net-misc/anydesk/anydesk-6.3.0.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-misc/anydesk/Manifest b/net-misc/anydesk/Manifest
index 60ff7c07658a..f0a2cd9b4276 100644
--- a/net-misc/anydesk/Manifest
+++ b/net-misc/anydesk/Manifest
@@ -1 +1,2 @@
DIST anydesk-6.2.1-amd64.tar.gz 6634159 BLAKE2B 03abb9c3a990a8e4b53505896ebef253c386f578a275ccbec55e85cbb27e5c0f140863c6dc407b1d0cc2f2975b63bcd13487e27425b16cd3fdb42fd71a646e97 SHA512 2a36eb0698d18d7f779a9c7b8a17b2a9964fc10ba1ce65a68555332e58fd316b8541ef5443c8f8a62a30711e8dd19174d599ac2cdccd581da645c6b6a7e000ae
+DIST anydesk-6.3.0-amd64.tar.gz 7050807 BLAKE2B f7a4eddb619d9dca50b97a43f45a7d3f87ac574ed8df0883f050827b2a9c433ca79a4715b9e8ba01f8d992b9adeeaea64743d31ba167c899f69620cba2923b61 SHA512 72a6b1a7427780fa33f5927d59485cc1ebdda6d20364cc6dde3eeacdaf7514852ebd6771669fbdfc113a069dd97eec3f2d18290a5cdd3a8d416d30610ef955b2
diff --git a/net-misc/anydesk/anydesk-6.3.0.ebuild b/net-misc/anydesk/anydesk-6.3.0.ebuild
new file mode 100644
index 000000000000..77d78ee0f0c6
--- /dev/null
+++ b/net-misc/anydesk/anydesk-6.3.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit desktop optfeature systemd xdg-utils
+
+DESCRIPTION="Feature rich multi-platform remote desktop application"
+HOMEPAGE="https://anydesk.com"
+SRC_URI="https://download.anydesk.com/linux/${P}-amd64.tar.gz
+ https://download.anydesk.com/linux/generic-linux/${P}-amd64.tar.gz"
+
+# OpeSSL/SSLeay, libvpx, zlib, Xiph, xxHash
+LICENSE="AnyDesk-TOS BSD BSD-2 openssl ZLIB"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+# x11-libs/gtkglext is required and cannot be mitigated: https://bugs.gentoo.org/868255
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-libs/glib:2
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/glu
+ media-libs/libglvnd
+ sys-auth/polkit
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+"
+BDEPEND="dev-util/patchelf"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_install() {
+ local dst="/opt/${PN}"
+
+ exeinto ${dst}
+ doexe ${PN}
+
+ dodir /opt/bin
+ dosym "${dst}/${PN}" "/opt/bin/${PN}"
+
+ newinitd "${FILESDIR}/anydesk.init" anydesk
+ systemd_newunit "${FILESDIR}/anydesk-4.0.1.service" anydesk.service
+
+ insinto /usr/share/polkit-1/actions
+ doins polkit-1/com.anydesk.anydesk.policy
+
+ insinto /usr/share
+ doins -r icons
+
+ domenu "${FILESDIR}/anydesk.desktop"
+
+ dodoc copyright README
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To run AnyDesk as background service use:"
+ elog
+ elog "OpenRC:"
+ elog "# rc-service anydesk start"
+ elog "# rc-update add anydesk default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start anydesk.service"
+ elog "# systemctl enable anydesk.service"
+ elog
+ elog "Please see README at /usr/share/doc/${PF}/README.bz2 for"
+ elog "further information about the linux version of AnyDesk."
+ elog
+ fi
+
+ optfeature_header "AnyDesk additional tools:"
+ optfeature "lsb_release" sys-apps/lsb-release
+ optfeature "lspci" sys-apps/pciutils
+ optfeature "lsusb" sys-apps/usbutils
+ optfeature "sound support" media-libs/libcanberra[gtk2]
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}