summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-12 14:23:30 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-12 14:25:07 -0400
commit1ba10d93746ee934fc5bd0a5089e87d897d77eee (patch)
tree5e704ae69cd314d05ad8462b54ddcea446d25357 /net-misc
parentdev-python/pdm: drop 2.8.0, 2.8.1, 2.9.0 (diff)
downloadgentoo-1ba10d93746ee934fc5bd0a5089e87d897d77eee.tar.gz
gentoo-1ba10d93746ee934fc5bd0a5089e87d897d77eee.tar.bz2
gentoo-1ba10d93746ee934fc5bd0a5089e87d897d77eee.zip
net-misc/ytfzf: add 2.6.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/ytfzf-2.6.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index 5c8433ed91aa..e328159c7298 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.6.0.tar.gz 3277853 BLAKE2B f99de6c473ee728d42290a647df9e0404dea92854203f306401d916e920814517dee3ddde8c8ff06cb7ff29f5a9b8f438867a1d9bc02aa6e208d030ad8b786a7 SHA512 fb9a1bd161a735a9c464948d6ba3664982eadd25456d5d565c57e478574949324dbf556620fb837c00bc4946c65336ec895f7c59e1169631effadf70085773c4
+DIST ytfzf-2.6.1.tar.gz 3278989 BLAKE2B 85ad83d9880e3e9e02a9a22b9f15e9ce88fafb1466f1694bd05766b24ac4505ce7da61e391d18f2973695394b89f5e4581f1c9e6588a6783a6fefa7adfaf7c67 SHA512 9266065352ae797bd5b8a2c71681b15599347ca38a519a21e84b42a0e8bb102c0937a02cbd6027c736ac0bdd7a6bc67fea664ecce5698032b4fef1ef0ec92c65
diff --git a/net-misc/ytfzf/ytfzf-2.6.1.ebuild b/net-misc/ytfzf/ytfzf-2.6.1.ebuild
new file mode 100644
index 000000000000..805a4b1030fa
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.6.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal +thumbnails"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ app-alternatives/awk
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ thumbnails? (
+ || (
+ media-gfx/ueberzugpp
+ media-gfx/ueberzug
+ )
+ )
+ )
+"
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}