summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/sobby
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/sobby')
-rw-r--r--net-misc/sobby/Manifest1
-rw-r--r--net-misc/sobby/files/sobby-conf-0.4.77
-rwxr-xr-xnet-misc/sobby/files/sobby-init-0.4.722
-rw-r--r--net-misc/sobby/files/sobby.xml14
-rw-r--r--net-misc/sobby/metadata.xml9
-rw-r--r--net-misc/sobby/sobby-0.4.8.ebuild59
6 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/sobby/Manifest b/net-misc/sobby/Manifest
new file mode 100644
index 000000000000..eebb120e4bae
--- /dev/null
+++ b/net-misc/sobby/Manifest
@@ -0,0 +1 @@
+DIST sobby-0.4.8.tar.gz 134766 SHA256 a711762c0722e9e7e01934c115dbffc7a233c033d66dbc5d58025af438516f48 SHA512 b946fc5c15257f74213fd6418933f8f4970ca58213a4c5bb33e1110f85964ce137eb5a9fdd0a601d8838310315241b9c29065493f4c9b33a8dbe09e77cc25492 WHIRLPOOL b2f6fd56725e6ef97df28b36090e63019b262fdd96e3d4ac04c05d2e41adc0e637f528cafec5c6f90344d67b5a92e84a2f043cba36e7532812fcf87c26099561
diff --git a/net-misc/sobby/files/sobby-conf-0.4.7 b/net-misc/sobby/files/sobby-conf-0.4.7
new file mode 100644
index 000000000000..b60192c99616
--- /dev/null
+++ b/net-misc/sobby/files/sobby-conf-0.4.7
@@ -0,0 +1,7 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+SOBBY_OPTS="-c /etc/sobby/sobby.xml"
+SOBBY_USER="sobby"
+SOBBY_GROUP="sobby"
diff --git a/net-misc/sobby/files/sobby-init-0.4.7 b/net-misc/sobby/files/sobby-init-0.4.7
new file mode 100755
index 000000000000..a5ab6eecb0e6
--- /dev/null
+++ b/net-misc/sobby/files/sobby-init-0.4.7
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use avahi
+}
+
+start() {
+ ebegin "Starting obby dedicated server"
+ start-stop-daemon -b --quiet --start --make-pidfile \
+ --pidfile /var/run/sobby.pid -u ${SOBBY_USER} -g ${SOBBY_GROUP} \
+ --exec /usr/bin/sobby -- ${SOBBY_OPTS}
+ eend $? "Failed to start sobby"
+}
+
+stop() {
+ ebegin "Stopping obby dedicated server"
+ start-stop-daemon --stop --quiet --pidfile /var/run/sobby.pid
+ eend $? "Failed to stop sobby"
+}
diff --git a/net-misc/sobby/files/sobby.xml b/net-misc/sobby/files/sobby.xml
new file mode 100644
index 000000000000..b61a89f211e5
--- /dev/null
+++ b/net-misc/sobby/files/sobby.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<sobby_config>
+ <settings>
+ <autosave_directory>/var/lib/sobby</autosave_directory>
+ <autosave_file>autosave.obby</autosave_file>
+ <autosave_interval>0</autosave_interval>
+ <command_directory></command_directory>
+ <name>Standalone obby server</name>
+ <password>secret</password>
+ <port>6522</port>
+ <post_save_hook></post_save_hook>
+ <session></session>
+ </settings>
+</sobby_config>
diff --git a/net-misc/sobby/metadata.xml b/net-misc/sobby/metadata.xml
new file mode 100644
index 000000000000..46ff3c52314f
--- /dev/null
+++ b/net-misc/sobby/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <longdescription>Stand alone server for the obby colaborative editor</longdescription>
+</pkgmetadata>
diff --git a/net-misc/sobby/sobby-0.4.8.ebuild b/net-misc/sobby/sobby-0.4.8.ebuild
new file mode 100644
index 000000000000..f8bf7b87526f
--- /dev/null
+++ b/net-misc/sobby/sobby-0.4.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils user
+
+DESCRIPTION="Standalone Obby server"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="avahi"
+
+RDEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ >=dev-cpp/libxmlpp-2.6
+ >=net-libs/net6-1.3.12
+ >=net-libs/obby-0.4.6[avahi=]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup sobby
+ enewuser sobby -1 -1 /var/lib/sobby sobby
+}
+
+src_configure() {
+ econf $(use_enable avahi zeroconf)
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}/${PN}-conf-0.4.7" sobby
+ newinitd "${FILESDIR}/${PN}-init-0.4.7" sobby
+
+ insinto /etc/sobby
+ doins "${FILESDIR}/sobby.xml"
+
+ keepdir /var/lib/sobby
+
+ fperms -R 0700 /var/lib/sobby
+ fperms -R 0700 /etc/sobby
+
+ fowners sobby:sobby /var/lib/sobby
+ fowners -R sobby:sobby /etc/sobby
+}
+
+pkg_postinst() {
+ elog "To start sobby, you can use the init script:"
+ elog " /etc/init.d/sobby start"
+ elog ""
+ elog "Please check the configuration in /etc/sobby/sobby.xml"
+ elog "before you start sobby"
+}