summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2018-10-23 01:08:27 +0300
committerJason Zaman <perfinion@gentoo.org>2018-11-27 21:58:38 +0800
commit7f05571e6d244c3cbdbb74ed29587b17ced48753 (patch)
tree2aaafd0dacec1bb18ce0e2120f3c8f2c3d92a845 /net-misc/rclone/rclone-1.44.ebuild
parentdev-ada/asis: Fix build with libgpr-2018 (diff)
downloadgentoo-7f05571e6d244c3cbdbb74ed29587b17ced48753.tar.gz
gentoo-7f05571e6d244c3cbdbb74ed29587b17ced48753.tar.bz2
gentoo-7f05571e6d244c3cbdbb74ed29587b17ced48753.zip
net-misc/rclone: bump 1.44
Closes: https://github.com/gentoo/gentoo/pull/10233 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'net-misc/rclone/rclone-1.44.ebuild')
-rw-r--r--net-misc/rclone/rclone-1.44.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/rclone/rclone-1.44.ebuild b/net-misc/rclone/rclone-1.44.ebuild
new file mode 100644
index 000000000000..2c530609ee7b
--- /dev/null
+++ b/net-misc/rclone/rclone-1.44.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build bash-completion-r1
+EGO_PN="github.com/ncw/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+
+ ./rclone genautocomplete bash ${PN}.bash || die
+ newbashcomp ${PN}.bash ${PN}
+
+ ./rclone genautocomplete zsh ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}