summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-01-05 02:26:59 -0500
committerTim Harder <radhermit@gentoo.org>2018-01-05 02:26:59 -0500
commit9abca29a95ff1f6eb90a2d97527af37fd6bb7892 (patch)
tree74c61ade13c37929be5fb66e3b9fd6a900f9c98c /net-misc/proxychains
parentnet-misc/proxychains: stabilize 4.12-r1 (diff)
downloadgentoo-9abca29a95ff1f6eb90a2d97527af37fd6bb7892.tar.gz
gentoo-9abca29a95ff1f6eb90a2d97527af37fd6bb7892.tar.bz2
gentoo-9abca29a95ff1f6eb90a2d97527af37fd6bb7892.zip
net-misc/proxychains: remove old
Diffstat (limited to 'net-misc/proxychains')
-rw-r--r--net-misc/proxychains/Manifest1
-rw-r--r--net-misc/proxychains/files/proxychains-4.10-makefile.patch45
-rw-r--r--net-misc/proxychains/proxychains-4.11.ebuild46
3 files changed, 0 insertions, 92 deletions
diff --git a/net-misc/proxychains/Manifest b/net-misc/proxychains/Manifest
index d73bad1a3b23..3be42d78392d 100644
--- a/net-misc/proxychains/Manifest
+++ b/net-misc/proxychains/Manifest
@@ -1,2 +1 @@
-DIST proxychains-ng-4.11.tar.bz2 31856 BLAKE2B 6ff8611a9c5d3c38a148e7d3c1109d0a738f95641e61b965d24a7fa71db0a4c803fa98d4b32349c11013858b0a9de83c3754eb8703c969140ea604c6a3f0de06 SHA512 241365e8a8bbcead22c7844a2970f59bfc1ee9ef9a42a3f800823e70008bd976835d705a8b9894980c46307dce3a886514051023bafef113845531cb5d928e1c
DIST proxychains-ng-4.12.tar.xz 31816 BLAKE2B 1267cd67ca3a21737abe9e510103c35e409a4afebf30c8917b7be8a84f1bb4edc55b6ec633eb5e63682ed2f6c277a464e16adaa52c70c8bac2588cfe7b36f1a6 SHA512 c1319065b2885fb16f1cd10092a25f49c20ace82dc67edcb2e8845fe79274fe63f5214d117eef3bfdffdc6aa8bf6904ea216047bd626043c5ecb36cd15d5560a
diff --git a/net-misc/proxychains/files/proxychains-4.10-makefile.patch b/net-misc/proxychains/files/proxychains-4.10-makefile.patch
deleted file mode 100644
index 5a3a2e1a6e8b..000000000000
--- a/net-misc/proxychains/files/proxychains-4.10-makefile.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- proxychains-ng-4.10.orig/Makefile
-+++ proxychains-ng-4.10/Makefile
-@@ -22,11 +22,9 @@
-
- GENH = src/version.h
-
--CFLAGS += -Wall -O0 -g -std=c99 -D_GNU_SOURCE -pipe
--NO_AS_NEEDED = -Wl,--no-as-needed
--LIBDL = -ldl
--LDFLAGS = -shared -fPIC $(NO_AS_NEEDED) $(LIBDL) -lpthread
--INC =
-+CFLAGS = -Wall -std=c99 -D_GNU_SOURCE
-+LIBS = -ldl -lpthread
-+INC =
- PIC = -fPIC
- AR = $(CROSS_COMPILE)ar
- RANLIB = $(CROSS_COMPILE)ranlib
-@@ -35,11 +33,11 @@
- LD_SET_SONAME = -Wl,-soname=
- INSTALL = ./tools/install.sh
-
--LDSO_PATHNAME = libproxychains4.$(LDSO_SUFFIX)
-+LDSO_PATHNAME = libproxychains.$(LDSO_SUFFIX)
-
- SHARED_LIBS = $(LDSO_PATHNAME)
- ALL_LIBS = $(SHARED_LIBS)
--PXCHAINS = proxychains4
-+PXCHAINS = proxychains
- ALL_TOOLS = $(PXCHAINS)
- ALL_CONFIGS = src/proxychains.conf
-
-@@ -81,11 +79,10 @@
- $(CC) $(CPPFLAGS) $(CFLAGS) $(CFLAGS_MAIN) $(INC) $(PIC) -c -o $@ $<
-
- $(LDSO_PATHNAME): $(LOBJS)
-- $(CC) $(LDFLAGS) $(LD_SET_SONAME)$(LDSO_PATHNAME) $(USER_LDFLAGS) \
-- -o $@ $(LOBJS)
-+ $(CC) $(LDFLAGS) -shared $(PIC) $(LD_SET_SONAME)$(LDSO_PATHNAME) -o $@ $(LOBJS) $(LIBS)
-
- $(ALL_TOOLS): $(OBJS)
-- $(CC) src/main.o src/common.o $(USER_LDFLAGS) -o $(PXCHAINS)
-+ $(CC) $(LDFLAGS) src/main.o src/common.o -o $(PXCHAINS) $(LIBS)
-
-
- .PHONY: all clean install install-config install-libs install-tools
diff --git a/net-misc/proxychains/proxychains-4.11.ebuild b/net-misc/proxychains/proxychains-4.11.ebuild
deleted file mode 100644
index 653885331f48..000000000000
--- a/net-misc/proxychains/proxychains-4.11.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs eutils multilib
-
-MY_PN=${PN}-ng
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="force any tcp connections to flow through a proxy (or proxy chain)"
-HOMEPAGE="https://github.com/rofl0r/proxychains-ng/"
-SRC_URI="https://github.com/rofl0r/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.10-makefile.patch
- sed -i "s/^\(LDSO_SUFFIX\).*/\1 = so.${PV}/" Makefile || die
- tc-export CC
-}
-
-src_configure() {
- # not autotools
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --sysconfdir="${EPREFIX}"/etc \
- || die
-}
-
-src_install() {
- dobin ${PN}
- dodoc AUTHORS README TODO
-
- dolib.so lib${PN}.so.${PV}
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV:0:1}
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
-
- insinto /etc
- doins src/${PN}.conf
-}