summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-10-04 16:42:17 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-10-04 16:45:53 +0200
commit1c33b816e5e6a9ccb8c007e5b7d7f50c269d24dd (patch)
tree7305749fa0afeb519453692addbd560290934065 /net-misc/netkit-bootparamd
parentnet-misc/curl: version bump to 7.56.0 (diff)
downloadgentoo-1c33b816e5e6a9ccb8c007e5b7d7f50c269d24dd.tar.gz
gentoo-1c33b816e5e6a9ccb8c007e5b7d7f50c269d24dd.tar.bz2
gentoo-1c33b816e5e6a9ccb8c007e5b7d7f50c269d24dd.zip
net-misc/netkit-bootparamd: Fix build against glibc-2.26 / libtirpc, bug 371385
Closes: https://bugs.gentoo.org/371385 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'net-misc/netkit-bootparamd')
-rw-r--r--net-misc/netkit-bootparamd/files/0.17-libtirpc.patch15
-rw-r--r--net-misc/netkit-bootparamd/metadata.xml3
-rw-r--r--net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r4.ebuild56
3 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/netkit-bootparamd/files/0.17-libtirpc.patch b/net-misc/netkit-bootparamd/files/0.17-libtirpc.patch
new file mode 100644
index 000000000000..1cdf263efb25
--- /dev/null
+++ b/net-misc/netkit-bootparamd/files/0.17-libtirpc.patch
@@ -0,0 +1,15 @@
+diff -ruN netkit-bootparamd-0.17.orig/rpc.bootparamd/main.c netkit-bootparamd-0.17/rpc.bootparamd/main.c
+--- netkit-bootparamd-0.17.orig/rpc.bootparamd/main.c 2000-07-22 16:23:56.000000000 -0000
++++ netkit-bootparamd-0.17/rpc.bootparamd/main.c 2017-10-04 14:17:49.887552574 -0000
+@@ -17,9 +17,11 @@
+
+
+ #ifdef __GLIBC__
++#ifndef _TIRPC_RPC_H
+ /* quick fix */
+ void get_myaddress(struct sockaddr_in *);
+ #endif
++#endif
+
+ int debug = 0;
+ int dolog = 0;
diff --git a/net-misc/netkit-bootparamd/metadata.xml b/net-misc/netkit-bootparamd/metadata.xml
index a535b8852829..dde8ad441958 100644
--- a/net-misc/netkit-bootparamd/metadata.xml
+++ b/net-misc/netkit-bootparamd/metadata.xml
@@ -5,4 +5,7 @@
<email>xmw@gentoo.org</email>
<name>Michael Weber</name>
</maintainer>
+<use>
+<flag name="libtirpc">Build against <pkg>net-libs/libtirpc</pkg> for RPC support</flag>
+</use>
</pkgmetadata>
diff --git a/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r4.ebuild b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r4.ebuild
new file mode 100644
index 000000000000..b52721ceadcf
--- /dev/null
+++ b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Netkit - bootparamd"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="mirror://debian/pool/main/n/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="+libtirpc"
+
+DEPEND="
+ !<=net-misc/netkit-bootpd-0.17-r2
+ libtirpc? ( net-libs/rpcsvc-proto net-libs/libtirpc )
+ !libtirpc? ( sys-libs/glibc[rpc(-)] )
+"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ eapply "${FILESDIR}"/0.17-jumpstart.patch
+ eapply "${FILESDIR}"/0.17-libtirpc.patch
+
+ # don't reset LDFLAGS (bug #335457), manpages into /usr/share/man
+ sed -i -e '/^LDFLAGS=/d ; /MANDIR=/s:man:share/man:' configure || die
+
+ sed -i -e 's:install -s:install:' rpc.bootparamd/Makefile || die
+
+ default
+}
+
+src_configure() {
+ if use libtirpc ; then
+ append-cflags -I/usr/include/tirpc
+ sed -i -e 's:^LIBS=$:LIBS=-ltirpc:' configure || die
+ fi
+
+ # Note this is not an autoconf configure
+ CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" ./configure || die
+}
+
+src_install() {
+ dodir usr/bin usr/sbin usr/share/man/man8
+ emake INSTALLROOT="${D}" install
+
+ newconfd "${FILESDIR}"/bootparamd.confd bootparamd
+ newinitd "${FILESDIR}"/bootparamd.initd bootparamd
+
+ doman rpc.bootparamd/bootparams.5
+ dodoc README ChangeLog
+ newdoc rpc.bootparamd/README README.bootparamd
+}