summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-10-03 13:40:51 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-10-03 13:40:51 -0700
commit7666992380a6ea303e04eec4457e1b11c2cda310 (patch)
treec51c842cfd9a44957d0652eedd639a8c943a46ae /net-misc/netifrc
parentnet-misc/netifrc: update LICENSE (diff)
downloadgentoo-7666992380a6ea303e04eec4457e1b11c2cda310.tar.gz
gentoo-7666992380a6ea303e04eec4457e1b11c2cda310.tar.bz2
gentoo-7666992380a6ea303e04eec4457e1b11c2cda310.zip
net-misc/netifrc: revbump, add busybox to dhcp (bug #846488), bug #861686
Closes: https://bugs.gentoo.org/846488 Closes: https://bugs.gentoo.org/861686 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc/netifrc')
-rw-r--r--net-misc/netifrc/netifrc-0.7.6-r1.ebuild91
-rw-r--r--net-misc/netifrc/netifrc-9999.ebuild17
2 files changed, 106 insertions, 2 deletions
diff --git a/net-misc/netifrc/netifrc-0.7.6-r1.ebuild b/net-misc/netifrc/netifrc-0.7.6-r1.ebuild
new file mode 100644
index 000000000000..54f749377303
--- /dev/null
+++ b/net-misc/netifrc/netifrc-0.7.6-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd udev
+
+DESCRIPTION="Gentoo Network Interface Management Scripts"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Netifrc"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/netifrc.git
+ https://github.com/gentoo/${PN}
+ "
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+IUSE="+dhcp"
+
+RDEPEND="
+ sys-apps/gentoo-functions
+ >=sys-apps/openrc-0.15
+ dhcp? (
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp[client]
+ sys-apps/busybox
+ )
+ )
+"
+BDEPEND="
+ kernel_linux? ( virtual/pkgconfig )
+"
+
+src_prepare() {
+ if [[ ${PV} == 9999 ]] ; then
+ local ver="git-${EGIT_VERSION:0:6}"
+ sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
+ einfo "Producing ChangeLog from Git history"
+ GIT_DIR="${S}/.git" git log >"${S}"/ChangeLog
+ fi
+
+ default
+}
+
+src_compile() {
+ MAKE_ARGS=(
+ PREFIX="${EPREFIX}"
+ UPREFIX="${EPREFIX}/usr"
+ UDEVDIR="${EPREFIX}$(get_udevdir)"
+ LIBEXECDIR="${EPREFIX}/lib/${PN}"
+ PF="${PF}"
+ )
+
+ emake "${MAKE_ARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKE_ARGS[@]}" DESTDIR="${D}" install
+ dodoc README CREDITS FEATURE-REMOVAL-SCHEDULE STYLE TODO
+
+ # Install the service file
+ local LIBEXECDIR="${EPREFIX}/lib/${PN}"
+ sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service.in" > "${T}/net_at.service" || die
+ systemd_newunit "${T}/net_at.service" 'net@.service'
+
+ local UNIT_DIR="$(systemd_get_systemunitdir)"
+ UNIT_DIR="${UNIT_DIR#"${EPREFIX}"}"
+ dosym net@.service "${UNIT_DIR}/net@lo.service"
+}
+
+pkg_postinst() {
+ udev_reload
+
+ if [[ ! -e "${EROOT}"/etc/conf.d/net && -z ${REPLACING_VERSIONS} ]]; then
+ elog "The network configuration scripts will use dhcp by"
+ elog "default to set up your interfaces."
+ elog "If you need to set up something more complete, see"
+ elog "${EROOT}/usr/share/doc/${P}/README"
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/net-misc/netifrc/netifrc-9999.ebuild b/net-misc/netifrc/netifrc-9999.ebuild
index 71acc5378ef6..54f749377303 100644
--- a/net-misc/netifrc/netifrc-9999.ebuild
+++ b/net-misc/netifrc/netifrc-9999.ebuild
@@ -26,9 +26,17 @@ IUSE="+dhcp"
RDEPEND="
sys-apps/gentoo-functions
>=sys-apps/openrc-0.15
- dhcp? ( || ( net-misc/dhcpcd net-misc/dhcp[client] ) )
+ dhcp? (
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp[client]
+ sys-apps/busybox
+ )
+ )
+"
+BDEPEND="
+ kernel_linux? ( virtual/pkgconfig )
"
-BDEPEND="kernel_linux? ( virtual/pkgconfig )"
src_prepare() {
if [[ ${PV} == 9999 ]] ; then
@@ -69,6 +77,7 @@ src_install() {
pkg_postinst() {
udev_reload
+
if [[ ! -e "${EROOT}"/etc/conf.d/net && -z ${REPLACING_VERSIONS} ]]; then
elog "The network configuration scripts will use dhcp by"
elog "default to set up your interfaces."
@@ -76,3 +85,7 @@ pkg_postinst() {
elog "${EROOT}/usr/share/doc/${P}/README"
fi
}
+
+pkg_postrm() {
+ udev_reload
+}