summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-03-01 15:38:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-01 15:38:35 +0200
commit5a426e488105c9361f70c4f5b0b48ccaab348d4e (patch)
tree9e58e0cebc273ee1bae5d1e04e81c21aa7ac2eaa /net-misc/axel
parentapp-misc/fdupes: add 2.3.0 (diff)
downloadgentoo-5a426e488105c9361f70c4f5b0b48ccaab348d4e.tar.gz
gentoo-5a426e488105c9361f70c4f5b0b48ccaab348d4e.tar.bz2
gentoo-5a426e488105c9361f70c4f5b0b48ccaab348d4e.zip
net-misc/axel: add 2.17.13, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-misc/axel')
-rw-r--r--net-misc/axel/Manifest1
-rw-r--r--net-misc/axel/axel-2.17.13.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/axel/Manifest b/net-misc/axel/Manifest
index 270463f6930d..545feeb4f3b6 100644
--- a/net-misc/axel/Manifest
+++ b/net-misc/axel/Manifest
@@ -1,2 +1,3 @@
DIST axel-2.17.10.tar.xz 274648 BLAKE2B ee89614412dda04092bd89821ce78d1fff9224d0e026b136d50f2c52a42bbb6a3a110dcf8c0e8110dfdb6a67d0b6aecf0322101f75016b38888f35f44849340c SHA512 f102ae742940d123364de49f01fe97cc146afc32adfb3776437a53ffef14fcca0c5926c39d6ac338fe2bd368529d18b0c885b694de48f7cb0e6d0195d2339437
DIST axel-2.17.11.tar.xz 279964 BLAKE2B d2a740b6a9471cc384ddb8556c3dce946edffc3ef7b2740306040cb22d4cbabea92064ed3b0f351235f004b1017cefb5b0fc8a427691a74f29880eec7e3f5b85 SHA512 111e8b3bbb70e717bee8b3c318c18d0121776301c609c0894376a371238dd839f5dae7edda6738d2b89296fd4b6ac1083399acf62308eaa479b6d70b080e65a1
+DIST axel-2.17.13.tar.xz 224788 BLAKE2B 07b3918277fa2a4b0cda5e989c3c001058cc0c8da52e479d56bd88956362cb1bbfa927b85ed870c5b0ddc599839fadb25aa5733bd295f060879d31c211913e16 SHA512 e36129de893c3c56fe89f7ff3accba9803b4e6d3b5094ed4266c10b33639b973c2fdc41beaf0a80d4fb5e62339580383497a15b4b7caad7d70c8fc581c0c4fc2
diff --git a/net-misc/axel/axel-2.17.13.ebuild b/net-misc/axel/axel-2.17.13.ebuild
new file mode 100644
index 000000000000..d2b41dac25da
--- /dev/null
+++ b/net-misc/axel/axel-2.17.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
+SRC_URI="https://github.com/axel-download-accelerator/axel/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="nls ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+DOCS=( doc/. )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl ssl=openssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with Portage, one can configure make.conf with:'
+ einfo
+ einfo 'FETCHCOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+ einfo 'RESUMECOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+}