summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-22 19:21:02 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-22 21:34:52 -0400
commit9e0e7f2fd50c5fb5c608a000eef939ad26bdac6c (patch)
tree5c06b6311a9a000c97c90c045b4f69f28e93fcce /net-mail
parenteclass: php-ext-source-r3 - Update documentation of src_prepare (diff)
downloadgentoo-9e0e7f2fd50c5fb5c608a000eef939ad26bdac6c.tar.gz
gentoo-9e0e7f2fd50c5fb5c608a000eef939ad26bdac6c.tar.bz2
gentoo-9e0e7f2fd50c5fb5c608a000eef939ad26bdac6c.zip
net-mail/offlineimap: version bump to 7.1.5
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.1.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index ce37a4a003bd..c30770086890 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -6,3 +6,4 @@ DIST offlineimap-7.1.1.tar.gz 701776 BLAKE2B 3af42b07e694ff1e40340cafbf14b0da689
DIST offlineimap-7.1.2.tar.gz 708014 BLAKE2B 848e7cfdec79a443529307503e49a86729be620862530ea438747c0d9f437548cf81f6f586211c8b7109f7a8e0d5a41ef06fb3f10d43938f60843d768ba19f46 SHA512 14bf6c561ad9cde72f71651970b98380139a016b689c75ed150027f8b71d9f1a646f6738e8fd74d6328103b25c17985ac494d9929568f90bb4be37b71a4de22d
DIST offlineimap-7.1.3.tar.gz 710766 BLAKE2B 6a4c80e0ef12a77a2cdd84ba79307636e9a08fdee1d989936c6f6c3d42eadb6d5c98fb8ce3ed530c49a4ad5c424702342b55b78fc5ba7e46dd6d276675b80cd7 SHA512 bf24be740b0e7607a1b53df7e872b5dd4b4c720601d99bd88a7ac8add078e5512b62b18c12177e28a00f510aaa8a48e25be82decfdd7ae2da76b671d44071e4a
DIST offlineimap-7.1.4.tar.gz 711048 BLAKE2B 0ff678339cf7c90159e3f7f64ac581469503584e356a773804e513200b40eb8b99c3dd6367c21a69fe8ef46bdac146b6571f6ef2f1292014009af20df890e682 SHA512 f2623a400de2fac339249f887529e1f02224ba40c5f739b4084b5b26d1f8b6f26faf2c248aeaecd48dd7f6cc27bdaa8b7691c10f3db3b9673a1a5338f435447c
+DIST offlineimap-7.1.5.tar.gz 711529 BLAKE2B 055fcaa714529407d404b45afc56f2b9c407865bbb6403a205f916926905c845c3dd9d025824de82850c17e2791c335aa11a38e9688c847d388ffaa97dbf5d2b SHA512 5e49e5e2f13a15f02036860d1622a79a1342c8d3c0ad1c3e56c32a90e9c6e439ed9b9de6b67e36bda19229e28bd17dcb132f093eb19524375b182dde079d6101
diff --git a/net-mail/offlineimap/offlineimap-7.1.5.ebuild b/net-mail/offlineimap/offlineimap-7.1.5.ebuild
new file mode 100644
index 000000000000..3258d1bf16b5
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.1.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}