summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-04-26 08:33:41 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-04-26 08:58:40 -0400
commit1f1f562771099a7dd31afcc39bdfdb4de6f3bc3e (patch)
treebf2ceeedde099f889e60f4ce73efc75b104ae3d9 /net-mail
parentx11-libs/libxkbcommon: Stabilize 1.7.0 arm64, #930692 (diff)
downloadgentoo-1f1f562771099a7dd31afcc39bdfdb4de6f3bc3e.tar.gz
gentoo-1f1f562771099a7dd31afcc39bdfdb4de6f3bc3e.tar.bz2
gentoo-1f1f562771099a7dd31afcc39bdfdb4de6f3bc3e.zip
net-mail/mailbox-count: add 0.0.8
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailbox-count/Manifest1
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.8.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/mailbox-count/Manifest b/net-mail/mailbox-count/Manifest
index 82e675aa3c26..ec8f43c86f95 100644
--- a/net-mail/mailbox-count/Manifest
+++ b/net-mail/mailbox-count/Manifest
@@ -1 +1,2 @@
DIST mailbox-count-0.0.6.tar.gz 21176 BLAKE2B 655815d463e14ee8c32cc955819d6b95d5359a644fb09433cb8ab303f07a98ce33b4c048be724253f30d8855a921abb5a7a29e62391ef8a1a9288e2f430710fc SHA512 285aeeaa8cfaade6c91a850154772e47aa212f73d1206c3c8262d08a15b95f15ce812152ca5acf79f5390f476ed6af52a73e03af4ab297e1268044a4a9ece6b5
+DIST mailbox-count-0.0.8.tar.gz 21179 BLAKE2B 09577d00716f872fbc07dd6b2ad2225a2e11c4bccb68bd22de9e9d78aa334fdece20654e9a5ea91b85d87c4204808693b7efc4eb2375691958bee69814ae5c34 SHA512 2be8d09b241b7a4fb5156e8051227fd87a6df9c8f84e9a14b6f6796a64963ba5e65fd3b96954fc0bfba4c93318dbc06528c771b568c94a1848b0905be466ff1f
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
new file mode 100644
index 000000000000..c2af7578eb1c
--- /dev/null
+++ b/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Count mailboxes in a SQL database"
+HOMEPAGE="https://michael.orlitzky.com/code/mailbox-count.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-lang/ghc-9.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )"
+
+src_install() {
+ haskell-cabal_src_install
+ dodoc "${S}/doc/${PN}rc.example"
+ doman "${S}/doc/man1/${PN}.1"
+}