summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2019-03-15 10:38:16 +0300
committerEray Aslan <eras@gentoo.org>2019-03-15 10:38:16 +0300
commitd90a3246db6e4d20a92632c266022dfcb85822fc (patch)
treead81f153e451568a8534df34e1a19a042b41b65d /net-mail/cyrus-imapd/files
parentsci-mathematics/why3-for-spark: use virtual/emacs on dependency (diff)
downloadgentoo-d90a3246db6e4d20a92632c266022dfcb85822fc.tar.gz
gentoo-d90a3246db6e4d20a92632c266022dfcb85822fc.tar.bz2
gentoo-d90a3246db6e4d20a92632c266022dfcb85822fc.zip
net-mail/cyrus-imapd: bump to 3.0.9
and fix underlinking perl modules Closes: https://bugs.gentoo.org/678754 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Eray Aslan <eras@gentoo.org>
Diffstat (limited to 'net-mail/cyrus-imapd/files')
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs-r1.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs-r1.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs-r1.patch
new file mode 100644
index 000000000000..4b1a51056f53
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs-r1.patch
@@ -0,0 +1,35 @@
+--- a/configure.ac 2017-07-15 07:26:38.375295969 +0200
++++ b/configure.ac 2017-07-15 07:28:33.250194410 +0200
+@@ -1351,7 +1351,9 @@
+ AC_CHECK_HEADERS([sys/capability.h sys/prctl.h], , have_libcap=no)
+ if test "$have_libcap" = "yes"; then
+ AC_DEFINE(HAVE_LIBCAP, [], [Do we have libcap system capabilities handling (Linux systems only)?])
+- LIBS="$LIBS -lcap"
++ LIBCAP="-lcap"
++ AC_SUBST(LIBCAP)
++ LIBS="$LIBS $LIBCAP"
+ fi
+ fi
+ ;;
+--- a/perl/imap/Makefile.PL.in 2019-02-25 15:43:44.370676803 +0100
++++ b/perl/imap/Makefile.PL.in 2019-02-25 15:44:02.595285944 +0100
+@@ -90,7 +90,7 @@
+ 'clean' => {'FILES' => 'libcyrperl.a cyradm'},
+ 'OBJECT' => 'IMAP.o',
+ 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
++ 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @LIBCAP@"],
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap",
+ 'EXE_FILES' => [cyradm],
+--- a/perl/sieve/managesieve/Makefile.PL.in 2019-02-25 15:42:40.852554632 +0100
++++ b/perl/sieve/managesieve/Makefile.PL.in 2019-02-25 15:43:05.029362231 +0100
+@@ -69,7 +69,7 @@
+ 'ABSTRACT' => 'Cyrus Sieve management interface',
+ 'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
+ 'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @SQLITE_LIBADD@ @MYSQL_LIBADD@ @PGSQL_LIBADD@"],
++ 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @SQLITE_LIBADD@ @MYSQL_LIBADD@ @PGSQL_LIBADD@ @LIBCAP@"],
+ 'CCFLAGS' => '@GCOV_CFLAGS@',
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I@top_srcdir@/lib -I@top_srcdir@/perl/sieve -I@top_srcdir@/perl/sieve/lib @SASLFLAGS@ @SSL_CPPFLAGS@",