summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-02 14:23:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-02 14:25:42 +0200
commitdbeadea75f7d3266168a355dd6f2e3ce72dfa8bc (patch)
treec31bf346b4361c98eb398fe1122373bff93d3ed4 /net-libs
parentdev-ada/gnatsymbolize: remove an SRC_URI (diff)
downloadgentoo-dbeadea75f7d3266168a355dd6f2e3ce72dfa8bc.tar.gz
gentoo-dbeadea75f7d3266168a355dd6f2e3ce72dfa8bc.tar.bz2
gentoo-dbeadea75f7d3266168a355dd6f2e3ce72dfa8bc.zip
net-libs/libupnp: bump to v1.14.7
Bug: https://bugs.gentoo.org/784590 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.14.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index 36e481b9fef5..fb38da8d00aa 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1,2 +1,3 @@
DIST libupnp-1.14.0.tar.gz 788668 BLAKE2B 8e77f49c6eacbaff2d4194f281f73e882d282b1af400b2d8e08111b7cb0b89305f3f06b8e0ebdf8eab35de39bcd2cd30be3ecb575d560c652e96bd7831eade40 SHA512 d7cf50e168aff2ef3ad08b4c383108d5044e4c9d2923088bb93423ee5fc555c32f0254f307cb86ea7c18197612cf2d2c6c681f82d99a6f01a68f86a21c6eecb7
DIST libupnp-1.14.5.tar.gz 782662 BLAKE2B 7b1a4f115d4fb545b26909d8f6feb0a017160876506f35a5932a0898e68104eb43d92f82872359bc7bccf27a05d41632296041bb450e8109758a0ff6b7dd8e58 SHA512 6a1587943fb76b860fa879b050ae46189cb9c6a514df3f00eefe8c3eaa268aa5c0307895b38cac22fac57a2918b925ecefde7c46b7c50f87cfcf86afd9ee180d
+DIST libupnp-1.14.7.tar.gz 785084 BLAKE2B 539388737dda0dd037cb50fbc1cca8bcdc43d1d706bdb7da19d1a184cfd61f3d585d9beef2a9c8c33f2cb2640a8479210ad6c358abd7193f304509df574e912c SHA512 92dd80d1bbaa64e6d3909c5bce73d0340fcd3a3c1d247a634bd48ec077ba0ce0b8224d1a670a66f6a8c591e31a54f15526071d62ae5460e85d582d7b6b67c674
diff --git a/net-libs/libupnp/libupnp-1.14.7.ebuild b/net-libs/libupnp/libupnp-1.14.7.ebuild
new file mode 100644
index 000000000000..4d8eccaa915d
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+MY_PN="pupnp"
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+# bug 733750
+RESTRICT="test"
+
+DOCS="ChangeLog"
+
+S="${WORKDIR}/${MY_PN}-release-${PV}"
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}