summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-07 13:44:12 +0000
committerSam James <sam@gentoo.org>2022-01-07 13:44:40 +0000
commitd9e7b988a5955df1417fa549635da4a7b0554e87 (patch)
tree4d8334eee86a9e6c5e7bac9c14da394034553968 /net-libs
parentapp-containers/lxd: fix the sed for OVMF path, add notes about vm's (diff)
downloadgentoo-d9e7b988a5955df1417fa549635da4a7b0554e87.tar.gz
gentoo-d9e7b988a5955df1417fa549635da4a7b0554e87.tar.bz2
gentoo-d9e7b988a5955df1417fa549635da4a7b0554e87.zip
net-libs/rpcsvc-proto: add 1.4.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rpcsvc-proto/Manifest1
-rw-r--r--net-libs/rpcsvc-proto/rpcsvc-proto-1.4.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/Manifest b/net-libs/rpcsvc-proto/Manifest
index e0324f8e649c..8cea904cb10d 100644
--- a/net-libs/rpcsvc-proto/Manifest
+++ b/net-libs/rpcsvc-proto/Manifest
@@ -1 +1,2 @@
DIST rpcsvc-proto-1.4.2.tar.gz 61788 BLAKE2B e941fa86088d690e3e80a501beb5169a51ff77b60d618f54db9d9fd5fb96c2b2a4277ab8d847dcdb29dadd2f6947d155b15cd8b6af1f1420e023da8637d555c0 SHA512 6769f9439e3f187eebdeef4ee8d54f8a6fee6f410e3137d0c1b26e61b705873932890856faff55b68c39aa702e456b36fe9410b85baf1ef9b20ee97f2158971a
+DIST rpcsvc-proto-1.4.3.tar.gz 62786 BLAKE2B 9f5cd14b2839c9be654bd237d4b8803536127217a684f21146efc94346c7163010bd30fd9a77e2a5ef3cf69655f3c88de99b8497c863968f02081099f174c115 SHA512 44afac7626147b7c4166bdd90556172bd5d7655f5837245985db7af3cc610de00e215c8cccc4ac6b6a0dd6d0a65d062dc19dab4d1cec0ef45818a7ff709df513
diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.3.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.3.ebuild
new file mode 100644
index 000000000000..0ce9e567204a
--- /dev/null
+++ b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="!<sys-libs/glibc-2.26
+ virtual/libintl"
+# sys-devel/gettext is only for libintl detection macros.
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # Use ${CHOST}-cpp, not 'cpp': bug #718138
+ # Ideally we should use @CPP@ but rpcgen makes it hard to use '${CHOST}-gcc -E'
+ sed -i -s "s/CPP = \"cpp\";/CPP = \"${CHOST}-cpp\";/" rpcgen/rpc_main.c || die
+}
+
+src_install() {
+ default
+
+ # provided by sys-fs/quota[rpc]
+ rm "${ED}"/usr/include/rpcsvc/rquota.{x,h} || die
+}