summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2020-08-24 19:25:07 +0100
committerIan Whyman <thev00d00@gentoo.org>2020-08-24 19:25:21 +0100
commit4073dfd4f685b52ad6acdc2456121f1d6140b2f5 (patch)
tree63dd38ed81a90e2ec1edb3e6f894730b608d33db /net-libs
parentdev-ruby/facter: 3.14.13 bump (diff)
downloadgentoo-4073dfd4f685b52ad6acdc2456121f1d6140b2f5.tar.gz
gentoo-4073dfd4f685b52ad6acdc2456121f1d6140b2f5.tar.bz2
gentoo-4073dfd4f685b52ad6acdc2456121f1d6140b2f5.zip
net-libs/libupnp: Version bump
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.14.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index e39fc3d24a7c..b419ccc3436a 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1,4 +1,5 @@
DIST libupnp-1.12.1.tar.gz 786818 BLAKE2B e44847dda5a7aeabb22a5b76cdc48d1dc69e70f7ecac85824199bf8d6e9b802cb717f2959f70690cc00babf1b554a0cb031995f80c28246b9eec670ebe7aaa90 SHA512 e4741f9245378529a15b8be7acec5af52d802ce84b82f110dab44c30da65fc2514d51d3bee6311643eb28146ea90bb3c97f44f800edb4f3ccccc1681f3e70f80
+DIST libupnp-1.14.0.tar.gz 788668 BLAKE2B 8e77f49c6eacbaff2d4194f281f73e882d282b1af400b2d8e08111b7cb0b89305f3f06b8e0ebdf8eab35de39bcd2cd30be3ecb575d560c652e96bd7831eade40 SHA512 d7cf50e168aff2ef3ad08b4c383108d5044e4c9d2923088bb93423ee5fc555c32f0254f307cb86ea7c18197612cf2d2c6c681f82d99a6f01a68f86a21c6eecb7
DIST libupnp-1.6.21.tar.bz2 1245353 BLAKE2B ca9ff07f88cfc77c3e3f7250ec1de6fb8c1ad3a918f556a7d37a6e994b67d825608edd3fd788a5b5979de72e3b25288225af3b5b8c58f54395682eef50bfc2d2 SHA512 65a2989497b941dfa1f7ac09fe44267de4a5231af25a304f0f6e754c7cbb578bdcb3c500188b5ebfbff9f579099db7501817d45e1724ef8e384d6d918bcdcdeb
DIST libupnp-1.6.25.tar.bz2 722731 BLAKE2B 7f1850a235683ecd19bc377cd5c80c9d7ee8f0ded123dfc00d29551d2fd97fb873ce4c30ce0d26d562c57470c266a573c37fed4c0db159c65c56c673271adf92 SHA512 c1426c2f855f34a56b96761602a35989867918b556ecf9784c9ce9580f6c6083950004909831bad331f3a4dfb70ef1bd287e026c71bbfde2613f77fe05ab9e1f
DIST libupnp-1.8.7.tar.gz 786079 BLAKE2B 5f7764c1392f881f420f27e21084f5c98a6fce711f82a3e83dd21e22bf01f25348cbea377b2fae2d69133e4926ae3f8bffcd870e31c4f29b0fe20214842765d5 SHA512 c02b82e33e4c4d85257f0d282e3c4fc1b14a9f42eebdf12318ce6fb75e620bb0c103f9531e87be744fe70898aae9f67db4b5a187a23bcace33427a5fe7d3293d
diff --git a/net-libs/libupnp/libupnp-1.14.0.ebuild b/net-libs/libupnp/libupnp-1.14.0.ebuild
new file mode 100644
index 000000000000..79c4ade3f905
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+DOCS="ChangeLog"
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${D}" -name '*.la' -delete || die
+}