summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-10-10 22:07:59 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-10-10 22:07:59 +0200
commit1bc38ed7e0be88fff47dd02b932ce40a631a6292 (patch)
treea66e046fcaf8047f96b5fbf72ee53ade2636ab05 /net-libs
parentwww-apps/phpsysinfo: add 3.4.4 (diff)
downloadgentoo-1bc38ed7e0be88fff47dd02b932ce40a631a6292.tar.gz
gentoo-1bc38ed7e0be88fff47dd02b932ce40a631a6292.tar.bz2
gentoo-1bc38ed7e0be88fff47dd02b932ce40a631a6292.zip
net-libs/libupnp: add 1.14.20
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.14.20.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index 124f57eeecf9..db99716d6d6c 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1 +1,2 @@
DIST libupnp-1.14.19.tar.gz 814300 BLAKE2B 119281a2e220b3b9398566b649d76fc047741a251097059920e84ef9376db03ee953ebf10934423a56613ad85aa9f77b777e33d92095b1468dfffb12e37e86bd SHA512 76ae3bf8b69fd649ede0b92e03b36a6cbc7a9df9fa7828386c97761df12f2ae6346dec9ab45f78e17eb793d4d225707ecb3a7628d7678287979115cd4ba65c49
+DIST libupnp-1.14.20.tar.gz 815274 BLAKE2B 3d331a28b8f1b6c98d1153c4320b9c5b4191e82858a4874a2ce7fc93eab30c3aed61ebb2982aa6a08037943edf7a2196dc5d2e1103238292c48b119e6a8ed3ea SHA512 8aabd054d3c311abab762d15c739e5e10801e9a6caf09540560be9497cb632fdfc2c86a61522ab0b24e9baf20020ab0dab2a6e8e253c9cc1a1047efc701ba563
diff --git a/net-libs/libupnp/libupnp-1.14.20.ebuild b/net-libs/libupnp/libupnp-1.14.20.ebuild
new file mode 100644
index 000000000000..96a5ae8a15b7
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.20.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="pupnp"
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-release-${PV}"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc +reuseaddr samples +ssl static-libs"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.14.12-disable-network-tests.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable blocking-tcp blocking-tcp-connections)
+ $(use_enable debug)
+ --enable-ipv6
+ $(use_enable reuseaddr)
+ $(use_enable samples)
+ $(use_enable ssl open_ssl)
+ $(use_enable static-libs static)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}