summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosiah Mullins <jomull01@protonmail.com>2020-01-09 12:36:40 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-01-13 08:09:43 +0200
commit8bb44727d1ea95d546b7c345d780f12a29fd5610 (patch)
tree65988e8337dbe3a7112ecc1a1b442297a0b04318 /net-libs/tox
parentnet-libs/tox: fix to openrc init script. (diff)
downloadgentoo-8bb44727d1ea95d546b7c345d780f12a29fd5610.tar.gz
gentoo-8bb44727d1ea95d546b7c345d780f12a29fd5610.tar.bz2
gentoo-8bb44727d1ea95d546b7c345d780f12a29fd5610.zip
net-libs/tox: drop old versions
This commit drops both tox 0.2.8 and tox 0.2.9. Signed-off-by: Josiah M. Mullins <JoMull01@protonmail.com> Bug: https://bugs.gentoo.org/694686 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs/tox')
-rw-r--r--net-libs/tox/Manifest1
-rw-r--r--net-libs/tox/metadata.xml1
-rw-r--r--net-libs/tox/tox-0.2.8.ebuild100
-rw-r--r--net-libs/tox/tox-0.2.9.ebuild101
4 files changed, 0 insertions, 203 deletions
diff --git a/net-libs/tox/Manifest b/net-libs/tox/Manifest
index 4aecac3f229f..64a9543861a6 100644
--- a/net-libs/tox/Manifest
+++ b/net-libs/tox/Manifest
@@ -1,3 +1,2 @@
DIST c-toxcore-0.2.10.tar.gz 515842 BLAKE2B 8e79f9a5045b5fef7825e5eb21644625607d86e472ec75ff45ff826712efa515682f9439181d52444b2a6a21472c6e78a3bea5bb7e356373faf733e2644a315d SHA512 8a6a78c52a67be0b727d0d3a8d1cece20ad716a2e694df0aa747eee7764f64c957458584f59db5e727a9803ed7b21adc1ad8d7e80fd6651e7774ca3504b38fc7
-DIST c-toxcore-0.2.8.tar.gz 502907 BLAKE2B 0ca2c861b3cd982b471fac5cf8bdacd21c3248118846cc17e51f33ba04cf3da12a64578744e47daa27bb8613762a6f562eb550f0b7af05a66696412f6d0a6360 SHA512 a23a87a74fe97091b00ea76676a22578ed1e2426ac777146bb6efc984f1bfd3fff0d7fb149691155b8e2db56e1e088a1884536e5b717ff5c45a87b437f275735
DIST c-toxcore-0.2.9.tar.gz 510806 BLAKE2B e67bdb86757d1431cc9d627dbc9afa9f54c3deb7814b38c2126849d10e9225aa58d2b23d175622678be74894ea197d3084719422a605d95eb4c55c4597a79f98 SHA512 917826a906a9ca4f04f34494616b8e36ec9e74c6b0709c50e8fe2dd9da680d170013fef242a3fe1b834e8e54cd2dde6be1c14e5d977f8531436ef34280bc3966
diff --git a/net-libs/tox/metadata.xml b/net-libs/tox/metadata.xml
index 9b67a0bb1737..bfbb95186f12 100644
--- a/net-libs/tox/metadata.xml
+++ b/net-libs/tox/metadata.xml
@@ -12,7 +12,6 @@
<use>
<flag name="av">Adds support for audio and video.</flag>
<flag name="dht-node">Enables DHT Bootstrap Node.</flag>
- <flag name="no-log">Log level: 0 (no debug info logged)</flag>
<flag name="log-error">Log level: 1</flag>
<flag name="log-warn">Log level: 2</flag>
<flag name="log-info">Log level: 3</flag>
diff --git a/net-libs/tox/tox-0.2.8.ebuild b/net-libs/tox/tox-0.2.8.ebuild
deleted file mode 100644
index 7e056d8ed926..000000000000
--- a/net-libs/tox/tox-0.2.8.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils systemd user
-
-MY_P="c-toxcore-${PV}"
-DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
-SRC_URI="https://github.com/TokTok/c-toxcore/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0/0.2"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+av daemon ipv6 no-log log-trace log-debug log-info log-warn +log-error static-libs test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="^^ ( no-log log-trace log-debug log-info log-warn log-error )"
-
-RDEPEND="
- av? ( media-libs/libvpx:=
- media-libs/opus )
- daemon? ( dev-libs/libconfig )
- >=dev-libs/libsodium-0.6.1:=[asm,urandom,-minimal]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- cmake-utils_src_prepare
- #remove faulty tests
- for testname in bootstrap lan_discovery save_compatibility tcp_relay; do
- sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
- done
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TOXAV=$(usex av)
- -DMUST_BUILD_TOXAV=$(usex av)
- -DBOOTSTRAP_DAEMON=$(usex daemon)
- -DENABLE_STATIC=$(usex static-libs)
- -DENABLE_SHARED=ON
- -DBUILD_AV_TEST=$(usex test)
- -DUSE_IPV6=$(usex test && usex ipv6)
- )
- if use test; then
- mycmakeargs+=(-DTEST_TIMEOUT_SECONDS=120)
- fi
- if use no-log; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="")
- einfo "logging disable"
- elif use log-trace; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="TRACE")
- einfo "Trace logging enabled"
- elif use log-debug; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="DEBUG")
- einfo "debug logging enabled"
- elif use log-info; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="INFO")
- einfo "info logging enabled"
- elif use log-warn; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="WARNING")
- einfo "warning logging enabled"
- else
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="ERROR")
- einfo "error logging enabled"
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use daemon; then
- newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon
- insinto /etc
- doins "${FILESDIR}"/tox-bootstrapd.conf
- systemd_dounit "${FILESDIR}"/tox-bootstrapd.service
- fi
-}
-
-pkg_postinst() {
- if use daemon; then
- enewgroup tox
- enewuser tox -1 -1 -1 tox
- if [[ -f ${EROOT%/}/var/lib/tox-dht-bootstrap/key ]]; then
- ewarn "Backwards compatability with the bootstrap daemon might have been"
- ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT%/}/var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT%/}/etc/tox-bootstrapd.conf"
- ewarn " ${EROOT%/}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox"
- fi
- fi
-}
diff --git a/net-libs/tox/tox-0.2.9.ebuild b/net-libs/tox/tox-0.2.9.ebuild
deleted file mode 100644
index f227ce28006d..000000000000
--- a/net-libs/tox/tox-0.2.9.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils systemd user
-
-MY_P="c-toxcore-${PV}"
-DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
-SRC_URI="https://github.com/TokTok/c-toxcore/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0/0.2"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+av daemon ipv6 log-debug +log-error log-info log-trace log-warn static-libs test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="?? ( log-debug log-error log-info log-trace log-warn )"
-
-RDEPEND="
- av? ( media-libs/libvpx:=
- media-libs/opus )
- daemon? ( dev-libs/libconfig )
- >=dev-libs/libsodium-0.6.1:=[asm,urandom,-minimal]"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- cmake-utils_src_prepare
- #remove faulty tests
- for testname in bootstrap lan_discovery save_compatibility tcp_relay tox_many_tcp; do
- sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
- done
-}
-
-src_configure() {
- local mycmakeargs=(
- -DAUTOTEST=$(usex test)
- -DBOOTSTRAP_DAEMON=$(usex daemon)
- -DBUILD_MISC_TESTS=$(usex test)
- -DBUILD_TOXAV=$(usex av)
- -DENABLE_SHARED=ON
- -DENABLE_STATIC=$(usex static-libs)
- -DMUST_BUILD_TOXAV=$(usex av))
- if use test; then
- mycmakeargs+=(
- -DBUILD_AV_TEST=$(usex av)
- -DTEST_TIMEOUT_SECONDS=120
- -DUSE_IPV6=$(usex ipv6))
- else
- mycmakeargs+=(
- -DBUILD_AV_TEST=OFF
- -DUSE_IPV6=OFF)
- fi
-
- if use log-trace; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="TRACE")
- elif use log-debug; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="DEBUG")
- elif use log-info; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="INFO")
- elif use log-warn; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="WARNING")
- elif use log-error; then
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="ERROR")
- else
- mycmakeargs+=(-DMIN_LOGGER_LEVEL="")
- einfo "Logging disabled"
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use daemon; then
- newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon
- insinto /etc
- doins "${FILESDIR}"/tox-bootstrapd.conf
- systemd_dounit "${FILESDIR}"/tox-bootstrapd.service
- fi
-}
-
-pkg_postinst() {
- if use daemon; then
- enewgroup tox
- enewuser tox -1 -1 -1 tox
- if [[ -f ${EROOT}/var/lib/tox-dht-bootstrap/key ]]; then
- ewarn "Backwards compatability with the bootstrap daemon might have been"
- ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT}/var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT}/etc/tox-bootstrapd.conf"
- ewarn " ${EROOT}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox"
- fi
- fi
-}