summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-10 11:24:12 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-11 18:49:16 +1000
commit20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3 (patch)
tree717d375d4bc34b50cfb78c9712a992489ed8d73b /net-libs/quiche
parenteclass: update rust usedep handling; address feedback (diff)
downloadgentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.gz
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.bz2
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.zip
*/*: fix rust eclass usedep/mutlilib handling; inherit order
The rust eclass has been updated to directly inject a required MULTILIB_USEDEP when requested. RUST_USEDEP has been renamed to RUST_REQUIRED_USE to be consistent with other eclasses. llvm-r1 should be imported after cargo and the eclass now enables this. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'net-libs/quiche')
-rw-r--r--net-libs/quiche/quiche-0.22.0-r2.ebuild4
-rw-r--r--net-libs/quiche/quiche-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-libs/quiche/quiche-0.22.0-r2.ebuild b/net-libs/quiche/quiche-0.22.0-r2.ebuild
index a767d0b6925c..750b1cadd8bf 100644
--- a/net-libs/quiche/quiche-0.22.0-r2.ebuild
+++ b/net-libs/quiche/quiche-0.22.0-r2.ebuild
@@ -195,9 +195,9 @@ windows-targets@0.52.5
ws2_32-sys@0.2.1
"
-RUST_USEDEP='${MULTILIB_USEDEP}'
+RUST_MULTILIB=1
-inherit multilib-minimal cargo cmake flag-o-matic rust-toolchain
+inherit cargo cmake flag-o-matic multilib-minimal rust-toolchain
DESCRIPTION="Implementation of the QUIC transport protocol and HTTP/3"
HOMEPAGE="https://github.com/cloudflare/quiche"
diff --git a/net-libs/quiche/quiche-9999.ebuild b/net-libs/quiche/quiche-9999.ebuild
index b01b0f1aace8..0433a526225c 100644
--- a/net-libs/quiche/quiche-9999.ebuild
+++ b/net-libs/quiche/quiche-9999.ebuild
@@ -195,9 +195,9 @@ windows-targets@0.52.5
ws2_32-sys@0.2.1
"
-RUST_USEDEP='${MULTILIB_USEDEP}'
+RUST_MULTILIB=1
-inherit multilib-minimal cargo cmake flag-o-matic rust-toolchain
+inherit cargo cmake flag-o-matic multilib-minimal rust-toolchain
DESCRIPTION="Implementation of the QUIC transport protocol and HTTP/3"
HOMEPAGE="https://github.com/cloudflare/quiche"