summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-23 09:02:04 +0000
committerSam James <sam@gentoo.org>2023-03-23 09:02:04 +0000
commitcce41eeab1aa114b6219d5bdda65af07541fbef4 (patch)
tree2499a2d293875d4d763d80eb21ae13a6014ca4a3 /net-libs/ntirpc
parentx11-libs/motif: Stabilize 2.3.8-r5 ppc64, #902789 (diff)
downloadgentoo-cce41eeab1aa114b6219d5bdda65af07541fbef4.tar.gz
gentoo-cce41eeab1aa114b6219d5bdda65af07541fbef4.tar.bz2
gentoo-cce41eeab1aa114b6219d5bdda65af07541fbef4.zip
net-libs/ntirpc: add 4.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/ntirpc')
-rw-r--r--net-libs/ntirpc/Manifest1
-rw-r--r--net-libs/ntirpc/ntirpc-4.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index d21e6fc29890..77fdaa5407b3 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1 +1,2 @@
DIST ntirpc-4.2.tar.gz 388418 BLAKE2B af875834515ae84d324302f2c0a36a7f34bb60ff95d2e30372f21541d558cec4337955fb72f1fbf43e3fcae75d706441dee658420bffe1f315578959405afb72 SHA512 fe241e3ac0e988d42425fe14c84970577693bd9ab1831069c753a18369150fb236fafea3d9b6c9d93faf93e918a93bf5367b914db819762c76e432ccffcb9328
+DIST ntirpc-4.3.tar.gz 388433 BLAKE2B 5d9051f6cad28d89172a85c6f0b9fd4fa81d34a90e1677822f3e9f0a11cedbbee7aed40456edc854f71aa92f9dfa6d133537453b7da3d9967293b1ecec4c8a55 SHA512 4728cea5ee920e96dcd0b94784c72d2e75b95a3de6599127531107e14676b10704d37180afe918315d818ced79d40eac4999eed69cf07ebe9799d68cdff1a758
diff --git a/net-libs/ntirpc/ntirpc-4.3.ebuild b/net-libs/ntirpc/ntirpc-4.3.ebuild
new file mode 100644
index 000000000000..e512976e7517
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake_src_configure
+}