summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-08-13 14:32:21 -0400
committerMike Gilbert <floppym@gentoo.org>2020-08-13 14:32:59 -0400
commit59599d71f02c9719d892e603335b64a661c9d383 (patch)
tree7aa2fdfba015dead40d0724e711b744f6d0a7dcc /net-libs/ntirpc
parentgames-emulation/dolphin: drop old (diff)
downloadgentoo-59599d71f02c9719d892e603335b64a661c9d383.tar.gz
gentoo-59599d71f02c9719d892e603335b64a661c9d383.tar.bz2
gentoo-59599d71f02c9719d892e603335b64a661c9d383.zip
net-libs/ntirpc: drop broken multilib code
Closes: https://bugs.gentoo.org/712282 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-libs/ntirpc')
-rw-r--r--net-libs/ntirpc/ntirpc-1.7.4.ebuild8
-rw-r--r--net-libs/ntirpc/ntirpc-1.8.1.ebuild6
-rw-r--r--net-libs/ntirpc/ntirpc-3.2.ebuild6
-rw-r--r--net-libs/ntirpc/ntirpc-3.3.ebuild6
4 files changed, 13 insertions, 13 deletions
diff --git a/net-libs/ntirpc/ntirpc-1.7.4.ebuild b/net-libs/ntirpc/ntirpc-1.7.4.ebuild
index 97b6f9397aba..bded25ea259b 100644
--- a/net-libs/ntirpc/ntirpc-1.7.4.ebuild
+++ b/net-libs/ntirpc/ntirpc-1.7.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-multilib
+inherit cmake
DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
@@ -21,10 +21,10 @@ RDEPEND="app-crypt/mit-krb5
rdma? ( sys-fabric/librdmacm )"
DEPEND="${RDEPEND}"
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
-DUSE_GSS="$(usex gssapi)"
-DUSE_RPC_RDMA="$(usex rdma)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/net-libs/ntirpc/ntirpc-1.8.1.ebuild b/net-libs/ntirpc/ntirpc-1.8.1.ebuild
index 931e0dca527e..7ec7709e46d4 100644
--- a/net-libs/ntirpc/ntirpc-1.8.1.ebuild
+++ b/net-libs/ntirpc/ntirpc-1.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-multilib
+inherit cmake
DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
@@ -20,10 +20,10 @@ RDEPEND="dev-libs/userspace-rcu
rdma? ( sys-fabric/librdmacm )"
DEPEND="${RDEPEND}"
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
-DUSE_GSS="$(usex gssapi)"
-DUSE_RPC_RDMA="$(usex rdma)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/net-libs/ntirpc/ntirpc-3.2.ebuild b/net-libs/ntirpc/ntirpc-3.2.ebuild
index 590f6fe9b48d..7027d1cf5ede 100644
--- a/net-libs/ntirpc/ntirpc-3.2.ebuild
+++ b/net-libs/ntirpc/ntirpc-3.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-multilib
+inherit cmake
DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
@@ -26,10 +26,10 @@ DEPEND="
${RDEPEND}
"
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
-DUSE_GSS="$(usex gssapi)"
-DUSE_RPC_RDMA="$(usex rdma)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/net-libs/ntirpc/ntirpc-3.3.ebuild b/net-libs/ntirpc/ntirpc-3.3.ebuild
index 16b76a069fd1..6e63e824706b 100644
--- a/net-libs/ntirpc/ntirpc-3.3.ebuild
+++ b/net-libs/ntirpc/ntirpc-3.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-multilib
+inherit cmake
DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
@@ -24,10 +24,10 @@ DEPEND="
${RDEPEND}
"
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
-DUSE_GSS="$(usex gssapi)"
-DUSE_RPC_RDMA="$(usex rdma)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}