summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libosip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libosip')
-rw-r--r--net-libs/libosip/Manifest2
-rw-r--r--net-libs/libosip/files/libosip-3.3.0-out-source-build.patch16
-rw-r--r--net-libs/libosip/libosip-3.6.0.ebuild36
-rw-r--r--net-libs/libosip/libosip-4.0.0.ebuild36
-rw-r--r--net-libs/libosip/metadata.xml5
5 files changed, 95 insertions, 0 deletions
diff --git a/net-libs/libosip/Manifest b/net-libs/libosip/Manifest
new file mode 100644
index 000000000000..b9c1c1b5d854
--- /dev/null
+++ b/net-libs/libosip/Manifest
@@ -0,0 +1,2 @@
+DIST libosip2-3.6.0.tar.gz 598496 SHA256 c9a18b0c760506d150017cdb1fa5c1cefe12b8dcbbf9a7e784eb75af376e96cd SHA512 58109fdc643673e811ce576374194d6d33b930ecec3221f31834471f52f5f2b2b30e5e331e245e33b2aafbff1aaa411d3a7657c25f3bb0b9d6cda0ae766fd538 WHIRLPOOL 7ba0050963aa2c997ee3dd3769bbcc7910586818c7fd76037044be9843cb47481fd024b9f77f3a99b6958e42ec3f68004063d7cf8b7713fd7c60a5eab6b17ef3
+DIST libosip2-4.0.0.tar.gz 644958 SHA256 bb2d228a41750fab397480002b0865f305f83a3840b1aa84851593593491b015 SHA512 995fc67c9a7536628ebaec9f4500bafa8a2f88081531bbae5194372b51102d556de28aea7d121e20cfda82b302a8a4ceb6488dbad61676930fdc13accb12b961 WHIRLPOOL 1c5df05f5317f6daaa7623f9868ed057ea3f07d84523088038bba366bdb955424b615a5bfb96754c89e046523e5db44075529a552439dc961a490d4e2eb57198
diff --git a/net-libs/libosip/files/libosip-3.3.0-out-source-build.patch b/net-libs/libosip/files/libosip-3.3.0-out-source-build.patch
new file mode 100644
index 000000000000..04a64ed39446
--- /dev/null
+++ b/net-libs/libosip/files/libosip-3.3.0-out-source-build.patch
@@ -0,0 +1,16 @@
+Fixed upstream:
+
+http://www.atosc.org/pipermail/osip/2010-February/009864.html
+
+--- src/test/Makefile.am 2010-02-11 17:51:43 +0000
++++ src/test/Makefile.am 2010-02-11 17:52:09 +0000
+@@ -49,7 +49,7 @@
+ @echo " *******************************"
+ @echo " ****** starting tests! ********"
+ @echo " *******************************"
+- @./$(top_srcdir)/src/test/tst ./$(top_srcdir)/src/test/res -c
++ @$(top_srcdir)/src/test/tst $(top_srcdir)/src/test/res -c
+
+ @echo ""
+ @echo "In case you have a doubt, send the generated"
+
diff --git a/net-libs/libosip/libosip-3.6.0.ebuild b/net-libs/libosip/libosip-3.6.0.ebuild
new file mode 100644
index 000000000000..e31eeba4fca3
--- /dev/null
+++ b/net-libs/libosip/libosip-3.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils autotools
+
+MY_PV=${PV%.?}-${PV##*.}
+MY_PV=${PV}
+MY_P=${PN}2-${MY_PV}
+DESCRIPTION="a simple way to support the Session Initiation Protocol"
+HOMEPAGE="http://www.gnu.org/software/osip/"
+SRC_URI="mirror://gnu/osip/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="amd64 ppc ~sparc x86 ~ppc-macos ~x86-macos"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.3.0-out-source-build.patch"
+ AT_M4DIR="scripts" eautoreconf
+}
+
+src_configure() {
+ econf --enable-mt \
+ $(use_enable test)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ dodoc AUTHORS ChangeLog FEATURES HISTORY README NEWS TODO || die
+}
diff --git a/net-libs/libosip/libosip-4.0.0.ebuild b/net-libs/libosip/libosip-4.0.0.ebuild
new file mode 100644
index 000000000000..faa6bd670689
--- /dev/null
+++ b/net-libs/libosip/libosip-4.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools versionator
+
+MY_PV=${PV%.?}-${PV##*.}
+MY_PV=${PV}
+MY_P=${PN}2-${MY_PV}
+DESCRIPTION="a simple way to support the Session Initiation Protocol"
+HOMEPAGE="http://www.gnu.org/software/osip/"
+SRC_URI="mirror://gnu/osip/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="2/$(get_version_component_range 1-2)"
+KEYWORDS="amd64 ppc ~sparc x86 ~ppc-macos ~x86-macos"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.3.0-out-source-build.patch"
+ AT_M4DIR="scripts" eautoreconf
+}
+
+src_configure() {
+ econf --enable-mt \
+ $(use_enable test)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog FEATURES HISTORY README NEWS TODO
+}
diff --git a/net-libs/libosip/metadata.xml b/net-libs/libosip/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/net-libs/libosip/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>