summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-07-19 00:31:02 +0000
committerSam James <sam@gentoo.org>2020-07-19 00:35:27 +0000
commitddde72881ac2e304d026697e581bc4e621977ad4 (patch)
tree1111f5669055eb99cdca6c4983ec479c223efd1e /net-libs/libntlm
parentdev-util/android-tools: fix 8.1.0_p1 for colon in CFLAGS (diff)
downloadgentoo-ddde72881ac2e304d026697e581bc4e621977ad4.tar.gz
gentoo-ddde72881ac2e304d026697e581bc4e621977ad4.tar.bz2
gentoo-ddde72881ac2e304d026697e581bc4e621977ad4.zip
net-libs/libntlm: security bump to 1.6
Bug: https://bugs.gentoo.org/717944 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libntlm')
-rw-r--r--net-libs/libntlm/Manifest1
-rw-r--r--net-libs/libntlm/libntlm-1.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/libntlm/Manifest b/net-libs/libntlm/Manifest
index 999846a7ee4c..ebccf07177e2 100644
--- a/net-libs/libntlm/Manifest
+++ b/net-libs/libntlm/Manifest
@@ -1 +1,2 @@
DIST libntlm-1.4.tar.gz 568414 BLAKE2B 2a622cd2d7b944128e29503845a3c9789efc9d14a93935ea24f9001d10b279969a8869f7ca68e6e36728638a32ce1ef693a5e8c28ab3bcaf702e114d4bf21dd3 SHA512 888ed2e9ee3e01a53bec951534966378a21c8a0baf555b65d97fed4408568c6b67f4199396cf3e61bb5a73b8e47dbe1333449369a92499e16478b0b60ac78274
+DIST libntlm-1.6.tar.gz 688608 BLAKE2B 8e545619b1fb00d778bbebf6ab9748005928a2669dab8c3d9c6285127b551c1bf039e1748a710e5eb551e7cbcb1a8775b57c21b163ca2a0206a4b9948b11df8a SHA512 d68bc6b5cd7f5f70385ba78275a810fa46e60f761f0949f2262eef35ae052661739ef17ce3fc4ab75f7e8cfc788b1ccd7766d4ff0ee78db08ea4de3e224653f2
diff --git a/net-libs/libntlm/libntlm-1.6.ebuild b/net-libs/libntlm/libntlm-1.6.ebuild
new file mode 100644
index 000000000000..037ed71be6a8
--- /dev/null
+++ b/net-libs/libntlm/libntlm-1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Microsoft's NTLM authentication (libntlm) library"
+HOMEPAGE="http://www.nongnu.org/libntlm/"
+SRC_URI="http://www.nongnu.org/${PN}/releases/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}