summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libgsasl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libgsasl')
-rw-r--r--net-libs/libgsasl/Manifest1
-rw-r--r--net-libs/libgsasl/files/libgsasl-gss-extra.patch21
-rw-r--r--net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild54
-rw-r--r--net-libs/libgsasl/metadata.xml9
4 files changed, 85 insertions, 0 deletions
diff --git a/net-libs/libgsasl/Manifest b/net-libs/libgsasl/Manifest
new file mode 100644
index 000000000000..1e6f3ea216ad
--- /dev/null
+++ b/net-libs/libgsasl/Manifest
@@ -0,0 +1 @@
+DIST libgsasl-1.8.0.tar.gz 1208417 SHA256 3adfb49f9c92a719dea855fd1840d698cde55d4648d332a69032ba8bea207720 SHA512 7e591d12404919559bf67590f862270ffcae2030a14097cdaf92820aa79619b3048541e9f83b3fcb98a84622c44a52ecaceeebb1be55b9e9f68fb1790ade8721 WHIRLPOOL 8ac141dad470a0f1df808093d99a56009b3e00593c9dd8a195f11a53b1bb24a3527e6986fd64ecc875842af305f9a72dd83d105070c0e3e0958622a3bb47cd97
diff --git a/net-libs/libgsasl/files/libgsasl-gss-extra.patch b/net-libs/libgsasl/files/libgsasl-gss-extra.patch
new file mode 100644
index 000000000000..a0f134a229f8
--- /dev/null
+++ b/net-libs/libgsasl/files/libgsasl-gss-extra.patch
@@ -0,0 +1,21 @@
+Gentoo bug #359005
+--- gl/m4/gss-extra.m4.orig 2010-12-14 12:57:08.000000000 +0000
++++ gl/m4/gss-extra.m4 2011-11-05 21:11:54.000000000 +0000
+@@ -19,7 +19,16 @@
+ AC_CHECK_FUNCS([gss_decapsulate_token])
+ AC_CHECK_FUNCS([gss_oid_equal])
+ AC_CHECK_FUNCS([gss_inquire_mech_for_saslname])
+- AC_CHECK_FUNCS([GSS_C_NT_HOSTBASED_SERVICE])
++ AC_MSG_CHECKING([for GSS_C_NT_HOSTBASED_SERVICE])
++ AC_EGREP_CPP(hostbased_service_gss_nt_yes, gssapi.h,
++ [#include <gssapi.h>
++ #ifdef GSS_C_NT_HOSTBASED_SERVICE
++ hostbased_service_gss_nt_yes
++ #endif],
++ [AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE,,
++ [Define if your GSSAPI implimentation defines GSS_C_NT_HOSTBASED_SERVICE])
++ AC_MSG_RESULT([yes])],
++ AC_MSG_RESULT([no]))
+ if test "$gssapi_impl" != "gss"; then
+ AC_CHECK_HEADERS([gssapi.h gssapi/gssapi.h])
+ if test "$ac_cv_header_gssapi_h$ac_cv_header_gssapi_gssapi_h" = "nono"; then
diff --git a/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild b/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..c7db36782bf3
--- /dev/null
+++ b/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="The GNU SASL library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="mirror://gnu/${PN/lib}/${P}.tar.gz"
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="idn gcrypt kerberos nls ntlm static-libs"
+DEPEND="
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ idn? ( net-dns/libidn )
+ kerberos? ( virtual/krb5 )
+ nls? ( >=sys-devel/gettext-0.18.1 )
+ ntlm? ( net-libs/libntlm )
+"
+RDEPEND="${DEPEND}
+ !net-misc/gsasl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-gss-extra.patch"
+ sed -i -e 's/ -Werror//' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local krb5_impl
+ if use kerberos; then
+ krb5_impl="--with-gssapi-impl="
+ krb5_impl+=$(has_version app-crypt/mit-krb5 && echo "mit" || echo "heimdal")
+ fi
+ econf \
+ $(use_with gcrypt libgcrypt) \
+ $(use_with idn stringprep) \
+ $(use_enable kerberos gssapi) \
+ ${krb5_impl} \
+ $(use_enable nls) \
+ $(use_enable ntlm) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ rm -f "${D}"/usr/lib*/lib*.la
+ fi
+}
diff --git a/net-libs/libgsasl/metadata.xml b/net-libs/libgsasl/metadata.xml
new file mode 100644
index 000000000000..b11afc2a3576
--- /dev/null
+++ b/net-libs/libgsasl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+<use>
+ <flag name='gcrypt'>Use <pkg>dev-libs/libgcrypt</pkg> for low-level crypto</flag>
+ <flag name='ntlm'>Add support for Microsoft's NTLM mechanism using <pkg>net-libs/libntlm</pkg></flag>
+</use>
+</pkgmetadata>