summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-09-08 12:51:55 -0500
committerMatt Turner <mattst88@gentoo.org>2021-04-28 00:19:57 -0400
commit830c859345812704f6366d4749ad12f1184511f8 (patch)
tree5c0f7f748ebd31a1f0fed63a22a03b7fb1654bd4 /net-libs/gtk-vnc
parentnet-libs/gtk-vnc: Version bump to 1.2.0 (diff)
downloadgentoo-830c859345812704f6366d4749ad12f1184511f8.tar.gz
gentoo-830c859345812704f6366d4749ad12f1184511f8.tar.bz2
gentoo-830c859345812704f6366d4749ad12f1184511f8.zip
net-libs/gtk-vnc: Fix musl build
Closes: https://bugs.gentoo.org/737266 Signed-off-by: Jory Pratt <anarchy@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild b/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild
index 5cd29c52ea67..f5587f996c28 100644
--- a/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild
@@ -54,8 +54,14 @@ src_configure() {
$(meson_feature introspection)
$(meson_feature pulseaudio)
$(meson_feature sasl)
- -Dwith-coroutine=auto # gthread on windows, libc ucontext elsewhere; neither has extra deps
$(meson_feature vala with-vala)
)
+
+ if use elibc_musl; then
+ emesonargs+=( -Dwith-coroutine=gthread )
+ else
+ emesonargs+=( -Dwith-coroutine=auto )
+ fi
+
meson_src_configure
}