summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-04-04 23:47:13 +0300
committerMart Raudsepp <leio@gentoo.org>2020-04-04 23:47:31 +0300
commit1fbf3f23cfb16b22a1ed1e43d3c504ffcaa20c7d (patch)
tree1b4d4054d59f10fca6a3041d28abf68582d22005 /net-libs/gtk-vnc
parentgnome-extra/gnome-software: bump to 3.34.2 (diff)
downloadgentoo-1fbf3f23cfb16b22a1ed1e43d3c504ffcaa20c7d.tar.gz
gentoo-1fbf3f23cfb16b22a1ed1e43d3c504ffcaa20c7d.tar.bz2
gentoo-1fbf3f23cfb16b22a1ed1e43d3c504ffcaa20c7d.zip
net-libs/gtk-vnc: bump to 1.0.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/Manifest2
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-1.0.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/net-libs/gtk-vnc/Manifest b/net-libs/gtk-vnc/Manifest
index 669f2263afbb..1c0f43e5aa23 100644
--- a/net-libs/gtk-vnc/Manifest
+++ b/net-libs/gtk-vnc/Manifest
@@ -1 +1,3 @@
DIST gtk-vnc-0.9.0.tar.xz 444736 BLAKE2B cf1afc0e856659012738060a584c72d7ad1b70459afd8bf92630d69cf32d380264814304a68a93d8a5a70d6573b6754658450005a2ea2b96f13ae03f9e87fcba SHA512 498b368eb53ac58172db280c80f9da71ce82b636c39f186046e4f674e44c574ff4b63c3f777acc79d32c17d70e4efcdc207768ed49b3d1842bc4b73618296215
+DIST gtk-vnc-1.0.0-patchset.tar.xz 9636 BLAKE2B 4f25fdf279e5a1718ea8dc42bdb59722630b363e4e289704b946ae788d593b5d95c56d0eb5315e30ff00c2eb4d3a9e5df366f74808f94e926a47c2f817b0f1ee SHA512 998771ceb28516f52bb083d872a1ad8aa22a7208c8a0ca94270f63d91cc7f7a0f99c4bb93f7a545d9a6c796fa063dd27b36a1cb9a3d7c9349a9d8372754ea929
+DIST gtk-vnc-1.0.0.tar.xz 215904 BLAKE2B 05ef0389c3ac307859228506adf55a5ed0f5d577078b82686ad97c9df180fc5c23d8dd030930c61f87b1bbd3cb6cee74c4485af4816b7b29fd53016c2d9b1d07 SHA512 63a40b9b284c4e46a92d5375ab3660b324ff27bfc572559d3b34d29fe4f7d24e976396b6688b8f3e3109d49dc5527075d128c43bb997507e68ddc0880b0ad148
diff --git a/net-libs/gtk-vnc/gtk-vnc-1.0.0.ebuild b/net-libs/gtk-vnc/gtk-vnc-1.0.0.ebuild
new file mode 100644
index 000000000000..c8939c84f659
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-1.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome.org vala meson python-any-r1 xdg
+
+DESCRIPTION="VNC viewer widget for GTK"
+HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection pulseaudio sasl +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=x11-libs/gdk-pixbuf-2.12.0:2
+ >=dev-libs/libgcrypt-1.5.0:0=
+ >=net-libs/gnutls-3.1.18:0=
+ >=sys-libs/zlib-1.2.5
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.26 )
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=x11-libs/cairo-1.2.0
+ >=x11-libs/libX11-1.6.5
+ pulseaudio? ( >=media-sound/pulseaudio-10.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.56.0:= )
+"
+# Keymap databases code is generated with python3; configure picks up $PYTHON exported from python-any-r1_pkg_setup
+# perl for pod2man
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ # Few fixes from origin/master + optionality patches filed as https://gitlab.gnome.org/GNOME/gtk-vnc/merge_requests/6
+ "${WORKDIR}"/patches
+)
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+ # Don't add -O2 explicitly to CFLAGS
+ sed -i -e "/'-O2'/d" meson.build
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_feature pulseaudio)
+ $(meson_feature sasl)
+ -Denable-werror=false
+ -Dwith-coroutine=auto # gthread on windows, libc ucontext elsewhere; neither has extra deps
+ $(meson_use vala with-vala)
+ )
+ meson_src_configure
+}