summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/NativeThread
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/NativeThread')
-rw-r--r--net-libs/NativeThread/Manifest1
-rw-r--r--net-libs/NativeThread/NativeThread-0_pre20080330.ebuild33
-rw-r--r--net-libs/NativeThread/files/Makefile.patch22
-rw-r--r--net-libs/NativeThread/metadata.xml9
4 files changed, 65 insertions, 0 deletions
diff --git a/net-libs/NativeThread/Manifest b/net-libs/NativeThread/Manifest
new file mode 100644
index 000000000000..ddc915f54a7f
--- /dev/null
+++ b/net-libs/NativeThread/Manifest
@@ -0,0 +1 @@
+DIST NativeThread-0_pre20080330.tar.bz2 2707 RMD160 6b93881f53a2ed89096d4a1900c3b48e08cb0201 SHA1 ca68ea04fcb1d9fd9f8aaed34a3e92a1de6539d9 SHA256 ae5277c25420fc76f59d296400c20562e37ff0ad4ecab63e537b9a053ac5802c
diff --git a/net-libs/NativeThread/NativeThread-0_pre20080330.ebuild b/net-libs/NativeThread/NativeThread-0_pre20080330.ebuild
new file mode 100644
index 000000000000..8bb9e1c3c9ff
--- /dev/null
+++ b/net-libs/NativeThread/NativeThread-0_pre20080330.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic java-pkg-2 toolchain-funcs
+
+DESCRIPTION="NativeThread for priorities on linux for freenet"
+HOMEPAGE="http://www.freenetproject.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-p2p/freenet-0.7
+ >=virtual/jdk-1.4"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/Makefile.patch
+}
+
+src_compile() {
+ append-flags -fPIC
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dolib.so lib${PN}.so || die
+}
diff --git a/net-libs/NativeThread/files/Makefile.patch b/net-libs/NativeThread/files/Makefile.patch
new file mode 100644
index 000000000000..e1f0209a6f3f
--- /dev/null
+++ b/net-libs/NativeThread/files/Makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile 2008-03-03 13:59:06.000000000 +0100
++++ Makefile.new 2008-03-30 16:27:12.000000000 +0200
+@@ -1,14 +1,14 @@
+-CC = gcc
+ INC = $(JAVA_HOME)/include
+-CFLAGS = -Wall -O3 -fPIC
+-LDFLAGS = -shared -Wl,-soname,libnative.so -I$(INC) -I$(INC)/linux
++CFLAGS += -Wall
++LDFLAGS += -shared -Wl,-soname,libnative.so -I$(INC) -I$(INC)/linux
+ LIBS = -lc
+
+ all: clean libNativeThread.so
+
+ NativeThread.class:
+- javac java/NativeThread.java
+- mv java/NativeThread.class freenet/support/io/
++ javac -classpath /usr/share/freenet/lib/freenet.jar NativeThread.java
++ mkdir -p freenet/support/io
++ mv NativeThread.class freenet/support/io/
+
+ libNativeThread.so: NativeThread.c NativeThread.h
+ $(CC) $(CFLAGS) -o libNativeThread.so $(LDFLAGS) NativeThread.c $(LIBS)
diff --git a/net-libs/NativeThread/metadata.xml b/net-libs/NativeThread/metadata.xml
new file mode 100644
index 000000000000..fed3658eec53
--- /dev/null
+++ b/net-libs/NativeThread/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau (Tommy[D])</name>
+ </maintainer>
+</pkgmetadata>
+