summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-12-02 09:48:09 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-12-02 12:21:41 -0500
commit7be52f52d69834fb3d5b59fd75df09bf2b64aee3 (patch)
tree1466b4f4b0d0f7aee8c0f236804a521ce3ddb9e4 /net-irc
parentx11-drivers/xf86-input-wacom: Update remote id to github (diff)
downloadgentoo-7be52f52d69834fb3d5b59fd75df09bf2b64aee3.tar.gz
gentoo-7be52f52d69834fb3d5b59fd75df09bf2b64aee3.tar.bz2
gentoo-7be52f52d69834fb3d5b59fd75df09bf2b64aee3.zip
net-irc/limnoria: Bump to 20191123 & EAPI 7, update PYCOMPAT
CVE: CVE-2019-19010 Bug: https://bugs.gentoo.org/701756 Package-Manager: Portage-2.3.80, Repoman-2.3.16 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org> Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/limnoria/Manifest1
-rw-r--r--net-irc/limnoria/limnoria-20191123.ebuild88
-rw-r--r--net-irc/limnoria/limnoria-99999999.ebuild12
3 files changed, 94 insertions, 7 deletions
diff --git a/net-irc/limnoria/Manifest b/net-irc/limnoria/Manifest
index 5068d8b10da8..5d6c449cdf1d 100644
--- a/net-irc/limnoria/Manifest
+++ b/net-irc/limnoria/Manifest
@@ -1,3 +1,4 @@
DIST limnoria-20150523.tar.gz 937583 BLAKE2B 7e27a3f415ad8623da3a149feb235bcf9261f936e93bd494e4c07183691d66003f3d3e18aa282f7bbb5cf41f44984ea78d96687d6047be731947abe971ed3877 SHA512 d94ea8fe64a648605e8e45317f3283fac837e8bfe1465407fa7522ea5e2259c64a0ea3aa4585313b5c21def735fa7b0e62d7774fabfc2647683efc2f4c38d599
DIST limnoria-20150829.tar.gz 939733 BLAKE2B 606284c5fb5d05e8c932a3c092a0a18a75f3b9fe4224c07113446be22e61707725a6bbe4ae8e0aa10d207a0988d72f832735faab5a0d3f8bcea4af810ca86c8a SHA512 51c941adf596716a610f6233a606958eae39fb90ad2ab02fcde670596c174b99196da7d29d31c438db0eeb79bd2d8c1067fdf21f0e6e42ba25a80cd5249b89a2
DIST limnoria-20171025.tar.gz 957078 BLAKE2B 74c1f7cb2ab9123706f265e471533dac4224848ba9a78a79749ca5cac7e9f67c33a884cef30706f3c36440b385ae2e1d5748f4b7aedaf9bfd8e38839d13e4865 SHA512 513a04b860e1fc1788de41238c858fa487899988111d9f5bfaa4acde6506dbd4bdf4dd26e48d268f6ca2f1b301b3e8d9aad8a2733013c09db69ffb4f925a7c12
+DIST limnoria-20191123.tar.gz 975077 BLAKE2B b5bc425013a30043c79a5dc53fc346e3b65cafbae154789f43634fc8beb4c7dcfaea34b0c1e22eae28e044eaa2801b0c29ef106fd6e2cc0095e6acbf4c4bf931 SHA512 5822f83a5d7fae0e45e526d9a72c1bbfd2acb7f625cff38e4d6e59222aca4c68204ae03069e991e274b108391cd4feff85783805657554771a7d24789589d14b
diff --git a/net-irc/limnoria/limnoria-20191123.ebuild b/net-irc/limnoria/limnoria-20191123.ebuild
new file mode 100644
index 000000000000..3b1067c7a695
--- /dev/null
+++ b/net-irc/limnoria/limnoria-20191123.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PN="Limnoria"
+MY_P="${MY_PN}-${MY_PV}"
+
+if [[ ${PV} == "99999999" ]]; then
+ EGIT_REPO_URI="https://github.com/ProgVal/${MY_PN}.git"
+ EGIT_BRANCH="testing"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ProgVal/${MY_PN}/archive/master-${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-master-${MY_PV}"
+fi
+
+DESCRIPTION="Python based extensible IRC infobot and channel bot"
+HOMEPAGE="https://supybot.aperio.fr/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="crypt ssl test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ !net-irc/supybot
+ !net-irc/supybot-plugins
+ "
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]]; then
+ git-r3_src_unpack
+ else
+ unpack ${P}.tar.gz
+ fi
+}
+
+python_prepare(){
+ if python_is_python3; then
+ einfo "Removing the RSS plugin because of clashes between libxml2's Python3"
+ einfo "bindings and feedparser."
+ rm -rf "plugins/RSS" || die
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/*
+}
+
+python_test() {
+ pushd "${T}" > /dev/null
+ PLUGINS_DIR="${BUILD_DIR}/lib/supybot/plugins"
+ EXCLUDE_PLUGINS=()
+ # intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
+ # runs successfully when running the tests on the installed system
+ EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Unix" )
+ # Runs despite --no-network (GH #1392)
+ EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Aka" )
+ "${PYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
+ --plugins-dir="${PLUGINS_DIR}" --no-network \
+ --disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \
+ || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+}
+
+pkg_postinst() {
+ elog "Complete user documentation is available at https://limnoria-doc.readthedocs.org/"
+ elog ""
+ elog "Use supybot-wizard to create a configuration file."
+ elog "Run supybot </path/to/config> to use the bot."
+}
diff --git a/net-irc/limnoria/limnoria-99999999.ebuild b/net-irc/limnoria/limnoria-99999999.ebuild
index 0c64a0acb20e..3b1067c7a695 100644
--- a/net-irc/limnoria/limnoria-99999999.ebuild
+++ b/net-irc/limnoria/limnoria-99999999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
@@ -52,7 +52,6 @@ src_unpack() {
}
python_prepare(){
- distutils-r1_python_prepare
if python_is_python3; then
einfo "Removing the RSS plugin because of clashes between libxml2's Python3"
einfo "bindings and feedparser."
@@ -68,13 +67,12 @@ python_install_all() {
python_test() {
pushd "${T}" > /dev/null
PLUGINS_DIR="${BUILD_DIR}/lib/supybot/plugins"
- # recommended by upstream, unknown random failure
- EXCLUDE_PLUGINS=( --exclude="${PLUGINS_DIR}/Scheduler" )
- # recommended by upstream, unknown random failure
- EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Filter" )
+ EXCLUDE_PLUGINS=()
# intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
# runs successfully when running the tests on the installed system
EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Unix" )
+ # Runs despite --no-network (GH #1392)
+ EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Aka" )
"${PYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
--plugins-dir="${PLUGINS_DIR}" --no-network \
--disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \