summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-08-25 11:13:47 -0600
committerArthur Zamarin <arthurzam@gentoo.org>2023-08-25 20:19:06 +0300
commit0dcb2ee769bb34dd02c816124cdb2ce3b200d35d (patch)
tree6d564be110a0455ee9032376efc6242f0a1af02e /net-irc
parentnet-irc/weechat: add missing dep on libcrypt (diff)
downloadgentoo-0dcb2ee769bb34dd02c816124cdb2ce3b200d35d.tar.gz
gentoo-0dcb2ee769bb34dd02c816124cdb2ce3b200d35d.tar.bz2
gentoo-0dcb2ee769bb34dd02c816124cdb2ce3b200d35d.zip
net-irc/weechat: xdg-utils.eclass => xdg.eclass
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/32350 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/weechat-4.0.4.ebuild14
-rw-r--r--net-irc/weechat/weechat-9999.ebuild14
2 files changed, 2 insertions, 26 deletions
diff --git a/net-irc/weechat/weechat-4.0.4.ebuild b/net-irc/weechat/weechat-4.0.4.ebuild
index fb63f18300f9..eb8d14968318 100644
--- a/net-irc/weechat/weechat-4.0.4.ebuild
+++ b/net-irc/weechat/weechat-4.0.4.ebuild
@@ -6,7 +6,7 @@ EAPI=8
LUA_COMPAT=( lua5-{1..4} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake lua-single python-single-r1 xdg-utils
+inherit cmake lua-single python-single-r1 xdg
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -184,15 +184,3 @@ src_test() {
die "required locale missing"
fi
}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index fb63f18300f9..eb8d14968318 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
LUA_COMPAT=( lua5-{1..4} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake lua-single python-single-r1 xdg-utils
+inherit cmake lua-single python-single-r1 xdg
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -184,15 +184,3 @@ src_test() {
die "required locale missing"
fi
}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}