summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-12 01:08:54 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-12 01:09:08 +0100
commitca34771d3176f17c2189b657fb0e46f2b7f8f13d (patch)
treef4d17de60cb2fed9e5d7a39516293aa07807e16a /net-irc/ii/ii-1.8.ebuild
parentsys-firmware/ipxe: Add USE=binary (diff)
downloadgentoo-ca34771d3176f17c2189b657fb0e46f2b7f8f13d.tar.gz
gentoo-ca34771d3176f17c2189b657fb0e46f2b7f8f13d.tar.bz2
gentoo-ca34771d3176f17c2189b657fb0e46f2b7f8f13d.zip
net-irc/ii: Version 1.8.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-irc/ii/ii-1.8.ebuild')
-rw-r--r--net-irc/ii/ii-1.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/ii/ii-1.8.ebuild b/net-irc/ii/ii-1.8.ebuild
new file mode 100644
index 000000000000..0a4bb49da753
--- /dev/null
+++ b/net-irc/ii/ii-1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="https://tools.suckless.org/ii/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
+ -e '/^CC/d' \
+ -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
+ config.mk || die
+ sed -i \
+ -e 's|@${CC}|$(CC)|g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ii
+ dodoc CHANGES FAQ README
+ doman *.1
+}