summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/eiwic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/eiwic')
-rw-r--r--net-irc/eiwic/Manifest1
-rw-r--r--net-irc/eiwic/eiwic-1.1.4.ebuild47
-rw-r--r--net-irc/eiwic/files/eiwic-1.1.3-ldflags.patch13
-rw-r--r--net-irc/eiwic/metadata.xml17
4 files changed, 78 insertions, 0 deletions
diff --git a/net-irc/eiwic/Manifest b/net-irc/eiwic/Manifest
new file mode 100644
index 000000000000..1dd650532a12
--- /dev/null
+++ b/net-irc/eiwic/Manifest
@@ -0,0 +1 @@
+DIST eiwic-1.1.4.tar.gz 117593 SHA256 6a49a859e46548f8ed005ed3c6338c64cc6725a08c32e5bbd075f8eee1eec800 SHA512 f4c6ac9853df2d26803bd3acd0987f6f4445ef0020a2e02b695eb362043f985eec8440ea9875c282e4f070e89b3ce7357947b99f86461a3bddef8cb2a85f8ce1 WHIRLPOOL f5147847f2884734ffcf90f532d0dd49ed96430dd7e76d223543fde30b8779db51a31314ea699ff132b7c8f773482850babe2be375b020fb914dfa9bf4ec1774
diff --git a/net-irc/eiwic/eiwic-1.1.4.ebuild b/net-irc/eiwic/eiwic-1.1.4.ebuild
new file mode 100644
index 000000000000..089232007a18
--- /dev/null
+++ b/net-irc/eiwic/eiwic-1.1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+WANT_AUTOMAKE=1.10
+inherit autotools eutils multilib
+
+DESCRIPTION="A modular IRC bot written in C"
+HOMEPAGE="https://github.com/lordi/Eiwic"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc ipv6"
+
+DOCS="AUTHORS ChangeLog README NEWS TODO sample.conf"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.3-ldflags.patch
+
+ sed -i \
+ -e "/^set MODULE_PATH/s:modules:/usr/$(get_libdir)/eiwic:" \
+ -e "/^load MODULE/s:$:.so:" \
+ sample.conf || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_lib_raptor_raptor_init=no #409417
+
+ econf \
+ $(use_enable debug vv-debug) \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/*
+}
+
+pkg_postinst() {
+ elog "You need a configuration file to run eiwic. A sample configuration"
+ elog "was installed to /usr/share/doc/${PF}"
+}
diff --git a/net-irc/eiwic/files/eiwic-1.1.3-ldflags.patch b/net-irc/eiwic/files/eiwic-1.1.3-ldflags.patch
new file mode 100644
index 000000000000..2870dc4f322b
--- /dev/null
+++ b/net-irc/eiwic/files/eiwic-1.1.3-ldflags.patch
@@ -0,0 +1,13 @@
+--- modules/Makefile.am
++++ modules/Makefile.am
+@@ -15,8 +15,8 @@
+ echo "$@ skipped."; \
+ else :;\
+ if test $(patsubst %.so,%.c, $@) -nt $@ -o ! -e $@; then \
+- echo "@CC@ @CFLAGS@ $(DEFS) $(INCLUDES) `$(ADD_BUILD_FLAGS)` -shared -fPIC $(patsubst %.so,%.c, $@) -o $@"; \
+- @CC@ @CFLAGS@ $(DEFS) $(INCLUDES) `$(ADD_BUILD_FLAGS)` -shared -fPIC $(patsubst %.so,%.c, $@) -o $@; \
++ echo "@CC@ @CFLAGS@ $(LDFLAGS) $(DEFS) $(INCLUDES) `$(ADD_BUILD_FLAGS)` -shared -fPIC $(patsubst %.so,%.c, $@) -o $@"; \
++ @CC@ @CFLAGS@ $(LDFLAGS) $(DEFS) $(INCLUDES) `$(ADD_BUILD_FLAGS)` -shared -fPIC $(patsubst %.so,%.c, $@) -o $@; \
+ else :; fi; \
+ fi
+
diff --git a/net-irc/eiwic/metadata.xml b/net-irc/eiwic/metadata.xml
new file mode 100644
index 000000000000..48d4032cb43b
--- /dev/null
+++ b/net-irc/eiwic/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <longdescription lang="en">
+ Eiwic is an IRC-bot written in pure C. It can be easily extended by own modules,
+ that can be loaded at runtime. It has an module API which is designed to make
+ the creation of own modules as easy as possible. Including "output routing",
+ TCP/IP socket interface and timer functions.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">lordi/Eiwic</remote-id>
+ </upstream>
+</pkgmetadata>