summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-16 18:40:27 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-16 18:40:43 +0100
commit7005ae03eb46029af953a8bf1b425d8cbfbf5154 (patch)
tree4d0f26b50c869260430b2e5d83f0c8c3a79c87cd /net-im
parentdev-perl/Eval-Closure: x86 stable wrt bug #570916 (diff)
downloadgentoo-7005ae03eb46029af953a8bf1b425d8cbfbf5154.tar.gz
gentoo-7005ae03eb46029af953a8bf1b425d8cbfbf5154.tar.bz2
gentoo-7005ae03eb46029af953a8bf1b425d8cbfbf5154.zip
net-im/pork: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
Gentoo-Bug: 570598 In addition, modernize to EAPI=6 and fix implicit declarations. Package-Manager: portage-2.2.26
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pork/files/pork-0.99.8.1-fix-buildsystem.patch101
-rw-r--r--net-im/pork/pork-0.99.8.1-r1.ebuild43
2 files changed, 144 insertions, 0 deletions
diff --git a/net-im/pork/files/pork-0.99.8.1-fix-buildsystem.patch b/net-im/pork/files/pork-0.99.8.1-fix-buildsystem.patch
new file mode 100644
index 000000000000..cb63980ee70e
--- /dev/null
+++ b/net-im/pork/files/pork-0.99.8.1-fix-buildsystem.patch
@@ -0,0 +1,101 @@
+Fix buildsystem to explicitly compile with -std=gnu89 to avoid
+differencs in inline semantics introduced in GCC5.
+https://bugs.gentoo.org/show_bug.cgi?id=570598
+
+Additionally, fix QA issues caused by implicit declarations, such as:
+* QA Notice: Package triggers severe warnings which indicate that it
+* may exhibit random runtime failures.
+* pork_inet.c:69:8: warning: implicit declaration of function ‘vasprintf’ [-Wimplicit-function-declaration]
+
+--- pork-0.99.8.1/configure.ac
++++ pork-0.99.8.1/configure.ac
+@@ -114,6 +114,8 @@
+
+ AC_CHECK_LIB(ncurses, resizeterm, AC_DEFINE(HAVE_RESIZETERM, 1, [Define to 1 if you have the 'resizeterm' function in -lncurses.]))
+
++AC_SEARCH_LIBS(stdscr, tinfo)
++
+ AC_CHECK_TYPE(u_int32_t, uint32_t)
+ if test "$ac_cv_type_u_int32_t" = "no"; then
+ AC_CHECK_TYPE(uint32_t, unsigned int)
+--- pork-0.99.8.1/Makefile.am
++++ pork-0.99.8.1/Makefile.am
+@@ -1,3 +1,5 @@
++AM_CFLAGS = -std=gnu89
++
+ SUBDIRS = \
+ src \
+ doc \
+--- pork-0.99.8.1/src/Makefile.am
++++ pork-0.99.8.1/src/Makefile.am
+@@ -6,7 +6,7 @@
+ endif
+
+
+-AM_CFLAGS = -funsigned-char -Imissing -Wall -Iprotocols -fPIC
++AM_CFLAGS = -funsigned-char -Imissing -Wall -Iprotocols -fPIC -std=gnu89
+ AM_CFLAGS += -DHELP_PATH=\"$(pkgdatadir)/help\" -DSYSTEM_PORKRC=\"$(pkgdatadir)/porkrc\"
+ AM_CFLAGS += $(PERL_CFLAGS) $(DEBUG_CFLAGS)
+
+--- pork-0.99.8.1/src/missing/Makefile.am
++++ pork-0.99.8.1/src/missing/Makefile.am
+@@ -1,5 +1,5 @@
+ INCLUDES = -I../../src
+-AM_CFLAGS = $(DEBUG_CFLAGS) $(PERL_CFLAGS)
++AM_CFLAGS = $(DEBUG_CFLAGS) $(PERL_CFLAGS) -std=gnu89
+
+ noinst_LIBRARIES = libmissing.a
+
+--- pork-0.99.8.1/src/pork_inet.c
++++ pork-0.99.8.1/src/pork_inet.c
+@@ -9,8 +9,9 @@
+
+ #include <config.h>
+
+-#include <unistd.h>
++#define _GNU_SOURCE 1
+ #include <stdio.h>
++#include <unistd.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
+--- pork-0.99.8.1/src/pork_screen_io.c
++++ pork-0.99.8.1/src/pork_screen_io.c
+@@ -14,6 +14,8 @@
+
+ #include <config.h>
+
++#define _GNU_SOURCE 1
++#include <stdio.h>
+ #include <unistd.h>
+ #include <ncurses.h>
+ #include <stdlib.h>
+--- pork-0.99.8.1/src/protocols/aim/Makefile.am
++++ pork-0.99.8.1/src/protocols/aim/Makefile.am
+@@ -1,5 +1,5 @@
+ INCLUDES = -I. -I.. -I../.. -I../../.. -I../../missing -Ilibfaim
+-AM_CFLAGS = $(DEBUG_CFLAGS) $(PERL_CFLAGS)
++AM_CFLAGS = $(DEBUG_CFLAGS) $(PERL_CFLAGS) -std=gnu89
+
+ noinst_LIBRARIES = libaim.a
+
+--- pork-0.99.8.1/src/protocols/irc/Makefile.am
++++ pork-0.99.8.1/src/protocols/irc/Makefile.am
+@@ -1,6 +1,6 @@
+ INCLUDES = -I. -I.. -I../.. -I../../.. -I../../missing
+
+-AM_CFLAGS = $(DEBUG_CFLAGS) $(PERL_CFLAGS)
++AM_CFLAGS = $(DEBUG_CFLAGS) $(PERL_CFLAGS) -std=gnu89
+
+ noinst_LIBRARIES = libirc.a
+
+--- pork-0.99.8.1/src/protocols/Makefile.am
++++ pork-0.99.8.1/src/protocols/Makefile.am
+@@ -3,6 +3,6 @@
+ endif
+
+ INCLUDES = -I. -I.. -I../.. -I../missing
+-AM_CFLAGS = $(DEBUG_CFLAGS) $(PERL_CFLAGS)
++AM_CFLAGS = $(DEBUG_CFLAGS) $(PERL_CFLAGS) -std=gnu89
+
+ SUBDIRS = $(irc_dir) aim
diff --git a/net-im/pork/pork-0.99.8.1-r1.ebuild b/net-im/pork/pork-0.99.8.1-r1.ebuild
new file mode 100644
index 000000000000..0a2e6809a59c
--- /dev/null
+++ b/net-im/pork/pork-0.99.8.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Console based AIM client that looks like ircII"
+HOMEPAGE="http://dev.ojnk.net/"
+SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="perl"
+
+RDEPEND="
+ perl? ( dev-lang/perl )
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable perl)
+}
+
+src_install() {
+ default
+
+ doman doc/pork.1
+ insinto /usr/share/pork/examples
+ doins examples/blist.txt
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README STYLE TODO QUICK_START
+}