summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-24 22:31:30 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-24 23:07:51 +0100
commit128d4ee34804a9619003d0e871f4c84b19ce4205 (patch)
treeb7c37cb6ee519b621d12066a629fe8e317f34b27 /net-im
parentdev-python/spyder-kernels: add version 2.2.0 (diff)
downloadgentoo-128d4ee34804a9619003d0e871f4c84b19ce4205.tar.gz
gentoo-128d4ee34804a9619003d0e871f4c84b19ce4205.tar.bz2
gentoo-128d4ee34804a9619003d0e871f4c84b19ce4205.zip
net-im/rocketchat-desktop-bin: add version 3.6.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.6.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index b782c46cc23e..dedc204467a2 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.5.7.x86_64.rpm 58632660 BLAKE2B 8003d269256fc5dc6b2d06bf17bf86de96ce9b8803f2dbe767051d286761516eb125226d5ca8d29979da60c58bc5560fcaa50ce2437a904f8ac1ea6f80eb609f SHA512 a42830f7c38ae5882a03e880a2ba5dd96735cfdc8635f8cf02441feaf2de360f2904bb44306bc9349f8fbda3dfb4bfcf6ad70474d2e62a4e574af02584c5ece4
+DIST rocketchat-3.6.0.x86_64.rpm 58643360 BLAKE2B 23e630112c8c28d39dbeb6824aa75d7289ad59e6cf061f2e61165511e2f57062832fb4ec64d9c985b1de94b0a28025b7f374d2a1428bc72eb6259f80cf79428d SHA512 8cc6b6842f9bdc3d13c4d293aa1aa75daba2bc66fab1262c051407fbe686fac1980e0abba3ccfa8d7cc6d96fc6391e24101b6baa9af3751edf4bf680968df142
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.6.0.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.6.0.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}