summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-10-14 19:01:38 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-10-14 19:38:50 +0100
commite42984246dcfff318b17b9a521a331ebfb431d5f (patch)
tree47ef8aa4885595330da6e942a67191c3a23990d1 /net-im/profanity
parentnet-libs/libsignal-protocol-c: add new package (diff)
downloadgentoo-e42984246dcfff318b17b9a521a331ebfb431d5f.tar.gz
gentoo-e42984246dcfff318b17b9a521a331ebfb431d5f.tar.bz2
gentoo-e42984246dcfff318b17b9a521a331ebfb431d5f.zip
net-im/profanity: add 0.7.1 ebuild
Copied from 0.6.0 ebuild with SRC_URI updated with latest URL advertised by upstream. Old URL doesn't work anymore. Bug: https://bugs.gentoo.org/697644 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'net-im/profanity')
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.7.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index 94dfe57fd10c..856411b5b46f 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1 +1,2 @@
DIST profanity-0.6.0.tar.gz 741812 BLAKE2B ba6cff070ee0e8a83b52677f6551c1d7397cd25993982d6b5390590a4924d902050504cb8803ee2741262b1409e4d75e9f223397f87f39d7dc86fcc56a0e5df6 SHA512 c7d8e74b764276f59fccfa029d45271032db315cdbf6e00deccbd611f202983a0930fed99021202333047acee9f3f0d7779cd9bb3628d2e5c4757e3de8c3629e
+DIST profanity-0.7.1.tar.gz 788754 BLAKE2B 447c761233ce6989081d3ed7a585d90713f4266dfc22ff816aea7c014f642f57989f7f767d8cf40cdd36c3152f45c6700f3905e0d12b864533aac61ac4dc7aaa SHA512 a6e159a5452ebb193dcff74dc8673de5dbc4bc5b2f2b8abc129641fc1b4b370aee9617dc0b26cfcc6aae58a1a900fda29356e61cdc17ee7ba69c879d6ccc2339
diff --git a/net-im/profanity/profanity-0.7.1.ebuild b/net-im/profanity/profanity-0.7.1.ebuild
new file mode 100644
index 000000000000..1e3e1435fe18
--- /dev/null
+++ b/net-im/profanity/profanity-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="https://profanity-im.github.io"
+SRC_URI="https://profanity-im.github.io/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify otr gpg xscreensaver"
+
+DEPEND="
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/libstrophe:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/ncurses:=[unicode]
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ otr? ( net-libs/libotr )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11 )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable otr) \
+ $(use_enable gpg pgp) \
+ $(use_with xscreensaver)
+}