summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/ekg2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/ekg2')
-rw-r--r--net-im/ekg2/Manifest1
-rw-r--r--net-im/ekg2/ekg2-0.3.1-r2.ebuild112
-rw-r--r--net-im/ekg2/ekg2-9999.ebuild109
-rw-r--r--net-im/ekg2/files/0001-Gentoo-use-vendor-dirs-for-perl-modules.patch25
-rw-r--r--net-im/ekg2/metadata.xml33
5 files changed, 280 insertions, 0 deletions
diff --git a/net-im/ekg2/Manifest b/net-im/ekg2/Manifest
new file mode 100644
index 000000000000..e399e9902885
--- /dev/null
+++ b/net-im/ekg2/Manifest
@@ -0,0 +1 @@
+DIST ekg2-0.3.1.tar.gz 1704772 SHA256 6ad360f8ca788d4f5baff226200f56922031ceda1ce0814e650fa4d877099c63 SHA512 dc107005f434f9e3011ff2be720b750b09c72fee1f9e1b47dfbf8af8eac1e27b24e028505a0d4928aedd1375a3245e93757410c742ff112ff5dac1e1a4f5a21c WHIRLPOOL 520f2eeb03e3edf3f3a622fcdcd3ca2952c69ac2503c1c5d76af5abdd7bdb12aa216d3ea22539bec2d996f5147bbf0e8198c9cc201677c8a1d2a65cecca0c1a7
diff --git a/net-im/ekg2/ekg2-0.3.1-r2.ebuild b/net-im/ekg2/ekg2-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..53629f3953f6
--- /dev/null
+++ b/net-im/ekg2/ekg2-0.3.1-r2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit autotools-utils eutils python-single-r1 versionator
+
+DESCRIPTION="Text-based, multi-protocol instant messenger"
+HOMEPAGE="http://www.ekg2.org"
+SRC_URI="http://pl.ekg2.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gadu gif gnutls gpg gpm gsm gtk idn jpeg ncurses nls
+ oracle perl python readline rss spell sqlite ssl threads unicode
+ xmpp xosd zlib"
+
+RDEPEND="
+ gpg? ( app-crypt/gpgme:= )
+ gsm? ( media-sound/gsm:= )
+ gtk? ( x11-libs/gtk+:2= )
+ idn? ( net-dns/libidn:= )
+ nls? ( virtual/libintl:= )
+ oracle? ( dev-db/oracle-instantclient-basic:= )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+ xosd? ( x11-libs/xosd:= )
+ zlib? ( sys-libs/zlib:= )
+
+ gadu? ( <net-libs/libgadu-1.12:=
+ gif? ( media-libs/giflib:= )
+ jpeg? ( virtual/jpeg:0= ) )
+ ncurses? ( sys-libs/ncurses:=[unicode?]
+ gpm? ( sys-libs/gpm:= )
+ spell? ( app-text/aspell:= ) )
+ rss? ( dev-libs/expat:= )
+ sqlite? ( dev-db/sqlite:3= )
+ xmpp? ( dev-libs/expat:=
+ gnutls? ( net-libs/gnutls:= ) )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/0001-Gentoo-use-vendor-dirs-for-perl-modules.patch
+)
+DOCS=(
+ AUTHORS docs/README docs/TODO
+ docs/events.txt docs/mouse.txt docs/sim.txt docs/voip.txt
+ docs/themes.txt docs/themes-en.txt
+ docs/ui-ncurses.txt docs/ui-ncurses-en.txt
+)
+
+# Due to MakeMaker being used to build Perl modules.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+pkg_pretend() {
+ if ! use gtk && ! use ncurses && ! use readline; then
+ ewarn 'ekg2 is being compiled without any frontend, you should consider'
+ ewarn 'enabling at least one of following USEflags:'
+ ewarn ' gtk, ncurses, readline.'
+ fi
+
+ if use gnutls && ! use ssl; then
+ ewarn 'You have enabled USE=gnutls without USE=ssl. The SSL support'
+ ewarn 'in ekg2 will be limited to the plugins supporting GnuTLS.'
+ fi
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_with gadu libgadu)
+ $(use_with gif)
+ # gnutls is jabber-specific
+ $(use xmpp && use_with gnutls libgnutls || echo '--without-libgnutls')
+ $(use_with gpg)
+ $(use_with gpm gpm-mouse)
+ $(use_with gsm libgsm)
+ $(use_with gtk)
+ $(use_with idn libidn)
+ $(use xmpp && echo '--with-expat' || use_with rss expat)
+ $(use_with jpeg libjpeg)
+ $(use_with ncurses)
+ $(use_with oracle logsoracle)
+ $(use_with perl)
+ $(use_with python)
+ $(use_with readline)
+ $(use_with spell aspell)
+ $(use_with sqlite sqlite3)
+ $(use_with ssl openssl)
+ $(use_with threads pthread)
+ $(use_with xosd libxosd)
+ $(use_with zlib)
+ $(use_enable nls)
+ $(use_enable unicode)
+ --with-inotify
+ --without-ioctld
+ --without-sqlite
+ --disable-remote
+ --enable-skip-relative-plugins-dir
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --modules
+}
diff --git a/net-im/ekg2/ekg2-9999.ebuild b/net-im/ekg2/ekg2-9999.ebuild
new file mode 100644
index 000000000000..58ac4ed65f8d
--- /dev/null
+++ b/net-im/ekg2/ekg2-9999.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="git://github.com/leafnode/${PN}.git
+ http://github.com/leafnode/${PN}.git"
+
+inherit git-r3
+#endif
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools-utils python-single-r1
+
+DESCRIPTION="Text-based, multi-protocol instant messenger"
+HOMEPAGE="http://www.ekg2.org"
+SRC_URI="http://pl.ekg2.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gadu gpm gpg gtk minimal ncurses nls nntp openssl
+ perl python readline rss spell sqlite ssl xmpp unicode zlib"
+
+RDEPEND="dev-libs/glib:2=
+ gadu? ( <net-libs/libgadu-1.12:0= )
+ gpg? ( app-crypt/gpgme:1= )
+ gtk? ( x11-libs/gtk+:2= )
+ nls? ( virtual/libintl:0= )
+ openssl? ( dev-libs/openssl:0= )
+ perl? ( dev-lang/perl:0= )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ rss? ( dev-libs/expat:0= )
+ ssl? ( net-libs/gnutls:0= )
+ xmpp? ( dev-libs/expat:0= )
+ zlib? ( sys-libs/zlib:0= )
+
+ ncurses? ( sys-libs/ncurses:5=[unicode=]
+ gpm? ( sys-libs/gpm:0= )
+ spell? ( app-text/aspell:0= ) )
+ sqlite? ( dev-db/sqlite:3= )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+DOCS=(
+ AUTHORS README.md docs/README docs/TODO
+ docs/events.txt docs/mouse.txt docs/sim.txt docs/voip.txt
+ docs/themes.txt docs/themes-en.txt
+ docs/ui-ncurses.txt docs/ui-ncurses-en.txt
+)
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+pkg_pretend() {
+ if ! use gtk && ! use ncurses && ! use readline; then
+ ewarn 'ekg2 is being compiled without any frontend. You should consider'
+ ewarn 'enabling at least one of following USEflags:'
+ ewarn ' gtk, ncurses, readline.'
+ fi
+}
+
+src_configure() {
+ myeconfargs=(
+ # direct plugin references
+ $(use_enable gadu gg)
+ $(use_enable gpg)
+ $(use_enable gtk)
+ $(use_enable ncurses)
+ $(use_enable nntp)
+ $(use_enable openssl sim)
+ $(use_enable perl)
+ $(use_enable python)
+ $(use_enable readline)
+ $(use_enable rss)
+ $(use_enable sqlite logsqlite)
+ $(use_enable xmpp jabber)
+
+ $(use_enable !minimal autoresponder)
+ $(use_enable !minimal jogger)
+ $(use_enable !minimal mail)
+ $(use_enable !minimal polchat)
+ $(use_enable !minimal rivchat)
+ $(use_enable !minimal sms)
+
+ # sqlite switch
+ --with-sqlite3
+
+ # optional deps
+ $(use_with gpm)
+ # do not pass --with-inotify as it will fail if check fails
+ $(use_with spell aspell)
+ $(use_with ssl gnutls)
+ $(use_with zlib)
+
+ # other magic
+ $(use_enable nls)
+ --with-perl-module-build-flags='INSTALLDIRS=vendor'
+ --enable-fast-configure
+ )
+ autotools-utils_src_configure
+}
diff --git a/net-im/ekg2/files/0001-Gentoo-use-vendor-dirs-for-perl-modules.patch b/net-im/ekg2/files/0001-Gentoo-use-vendor-dirs-for-perl-modules.patch
new file mode 100644
index 000000000000..010b22fc976c
--- /dev/null
+++ b/net-im/ekg2/files/0001-Gentoo-use-vendor-dirs-for-perl-modules.patch
@@ -0,0 +1,25 @@
+From 804370c1ad2f94937ac9184dbbb40354885ea6be Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 6 Apr 2011 16:19:46 +0200
+Subject: [PATCH] [Gentoo] use vendor dirs for perl modules.
+
+---
+ plugins/perl/Makefile.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/plugins/perl/Makefile.in b/plugins/perl/Makefile.in
+index 84d378b..309e2e2 100644
+--- a/plugins/perl/Makefile.in
++++ b/plugins/perl/Makefile.in
+@@ -594,7 +594,7 @@ all-local:
+ set -e; for dir in $(perl_dirs); do \
+ cd $$dir && \
+ if [ ! -f Makefile ]; then \
+- $(PERL) Makefile.PL; \
++ $(PERL) Makefile.PL INSTALLDIRS=vendor; \
+ fi && \
+ $(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(AM_CFLAGS) $(CFLAGS)" && \
+ cd ..; \
+--
+1.7.4.1
+
diff --git a/net-im/ekg2/metadata.xml b/net-im/ekg2/metadata.xml
new file mode 100644
index 000000000000..9235b334061f
--- /dev/null
+++ b/net-im/ekg2/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+
+ <use>
+ <!-- 0.3* flags -->
+ <flag name='gif' restrict='=net-im/ekg2-0.3*'>
+ GIF token support for Gadu-Gadu protocol.</flag>
+ <flag name='gnutls'>Enable SSL/TLS support through GnuTLS
+ for the plugins supporting it. If 'ssl' is enabled too, GnuTLS will
+ be preferred where possible (and OpenSSL will be used
+ elsewhere).</flag>
+ <flag name='jpeg'>JPEG token support for Gadu-Gadu protocol.</flag>
+ <flag name='ssl' restrict='=net-im/ekg2-0.3*'>
+ Enable the complete SSL/TLS support through OpenSSL.
+ This also enables the 'sim' plugin which relies on OpenSSL.</flag>
+ <flag name='oracle'>Support logging messages into Oracle database.</flag>
+
+ <!-- common and modern flags -->
+ <flag name='gadu'>Enable Gadu-Gadu protocol support (requires
+ <pkg>net-libs/libgadu</pkg>).</flag>
+ <flag name='gpg'>Enable jabber message encryption through
+ <pkg>app-crypt/gpgme</pkg>.</flag>
+ <flag name='minimal'>Disable building extra plugins with no additional
+ deps.</flag>
+ <flag name='openssl'>Support encryption in sim plugin, using OpenSSL.</flag>
+ <flag name='sqlite'>Support logging messages into SQLite3 database.</flag>
+ </use>
+</pkgmetadata>