summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-ftp/weex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-ftp/weex')
-rw-r--r--net-ftp/weex/Manifest1
-rw-r--r--net-ftp/weex/files/formatstring.patch11
-rw-r--r--net-ftp/weex/files/weex-2.6.1.5-va_list.patch23
-rw-r--r--net-ftp/weex/metadata.xml10
-rw-r--r--net-ftp/weex/weex-2.6.1.5-r1.ebuild32
5 files changed, 77 insertions, 0 deletions
diff --git a/net-ftp/weex/Manifest b/net-ftp/weex/Manifest
new file mode 100644
index 000000000000..f231adbb5dd3
--- /dev/null
+++ b/net-ftp/weex/Manifest
@@ -0,0 +1 @@
+DIST weex-2.6.1.5.tar.gz 206972 SHA256 d4f307293ff18230641098723273ba6243e5fbeb5af85f89a8938b826e91ac38 SHA512 4a33761a22f7df4b610b86b74104a1eb4836851345092ac730758026ef5e4fd5e4df3e670b5eefe1230f0ccfce85282ffa79007a0056df774cf1ebce191a90bc WHIRLPOOL cc85576e9b65bc0553bc128a21e60c15fba765fde41788ee911c59aff281a9333ec1c48c1184fae5df4e0ea064c76c591c7aee63b5eb26effcd5ac99847f2883
diff --git a/net-ftp/weex/files/formatstring.patch b/net-ftp/weex/files/formatstring.patch
new file mode 100644
index 000000000000..06ad28b88365
--- /dev/null
+++ b/net-ftp/weex/files/formatstring.patch
@@ -0,0 +1,11 @@
+--- src/log.c.old 2005-10-02 03:49:34.495603240 +0200
++++ src/log.c 2005-10-02 03:50:18.064979688 +0200
+@@ -183,7 +183,7 @@ void log_flush(void)
+
+ fp=log_open();
+ for(i=0;i<max_log;i++){
+- fprintf(fp,log_str[i]);
++ fprintf(fp,"%s",log_str[i]);
+ free(log_str[i]);
+ }
+ free(log_str);
diff --git a/net-ftp/weex/files/weex-2.6.1.5-va_list.patch b/net-ftp/weex/files/weex-2.6.1.5-va_list.patch
new file mode 100644
index 000000000000..70b3ebcdd832
--- /dev/null
+++ b/net-ftp/weex/files/weex-2.6.1.5-va_list.patch
@@ -0,0 +1,23 @@
+--- src/strlib.c.orig 2003-08-18 11:52:38.000000000 +0200
++++ src/strlib.c 2004-07-05 20:32:48.853638760 +0200
+@@ -167,14 +167,16 @@
+ -------------------------------------------------- */
+ char *str_dup_printf(const char *format, ...)
+ {
+- va_list ap1,ap2;
++ va_list ap1;
+ char *ptr;
+
+ va_start(ap1,format);
+- G_VA_COPY(ap2,ap1);
++ //G_VA_COPY(ap2,ap1);
+ ptr=str_malloc(printf_string_upper_bound(format,ap1));
+- vsprintf(ptr,format,ap2);
+- va_end(ap2);
++ va_end(ap1);
++ va_start(ap1,format);
++ vsprintf(ptr,format,ap1);
++ va_end(ap1);
+
+ return(ptr);
+ }
diff --git a/net-ftp/weex/metadata.xml b/net-ftp/weex/metadata.xml
new file mode 100644
index 000000000000..ca1c1c5c0efb
--- /dev/null
+++ b/net-ftp/weex/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">weex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-ftp/weex/weex-2.6.1.5-r1.ebuild b/net-ftp/weex/weex-2.6.1.5-r1.ebuild
new file mode 100644
index 000000000000..16c6fccd521e
--- /dev/null
+++ b/net-ftp/weex/weex-2.6.1.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Automates maintaining a web page or other FTP archive"
+HOMEPAGE="http://weex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="" #nls
+
+DEPEND="sys-libs/ncurses"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-va_list.patch"
+ epatch "${FILESDIR}/formatstring.patch"
+}
+
+src_configure() {
+ econf --disable-nls #532502
+}
+
+src_install() {
+ default
+ dodoc doc/TODO* doc/README* doc/FAQ* doc/sample* doc/ChangeLog* \
+ doc/BUG* doc/THANK*
+}