summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-15 03:45:51 +0000
committerSam James <sam@gentoo.org>2021-06-15 03:45:51 +0000
commit6f4c9bd084526bce777418dc7a1d269046413bea (patch)
treea3f5d582a5b1e2c2e6ebd21a2ed0d203b47a4ad0 /net-dns
parentdev-libs/xapian: workaround build failure with GCC 11 for 1.2.25 (diff)
downloadgentoo-6f4c9bd084526bce777418dc7a1d269046413bea.tar.gz
gentoo-6f4c9bd084526bce777418dc7a1d269046413bea.tar.bz2
gentoo-6f4c9bd084526bce777418dc7a1d269046413bea.zip
net-dns/dnsdist: fix build with GCC 11, protobuf no longer optional
* Fix build with GCC 11 * Upstream made protobuf mandatory Closes: https://bugs.gentoo.org/790719 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsdist/dnsdist-1.6.0.ebuild9
-rw-r--r--net-dns/dnsdist/files/dnsdist-1.6.0-gcc11-missing-include.patch24
2 files changed, 28 insertions, 5 deletions
diff --git a/net-dns/dnsdist/dnsdist-1.6.0.ebuild b/net-dns/dnsdist/dnsdist-1.6.0.ebuild
index 3340f22db784..84866fb8314e 100644
--- a/net-dns/dnsdist/dnsdist-1.6.0.ebuild
+++ b/net-dns/dnsdist/dnsdist-1.6.0.ebuild
@@ -26,12 +26,12 @@ RDEPEND="acct-group/dnsdist
acct-user/dnsdist
>=dev-libs/boost-1.35:=
dev-libs/libedit:=
+ >=dev-libs/protobuf-3:=
dnscrypt? ( dev-libs/libsodium:= )
dnstap? ( dev-libs/fstrm:= )
doh? ( www-servers/h2o:=[libh2o] )
lmdb? ( dev-db/lmdb:= )
regex? ( dev-libs/re2:= )
- remote-logging? ( >=dev-libs/protobuf-3:= )
snmp? ( net-analyzer/net-snmp:= )
ssl? (
gnutls? ( net-libs/gnutls:= )
@@ -44,9 +44,9 @@ RDEPEND="acct-group/dnsdist
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-src_prepare() {
- default
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-gcc11-missing-include.patch
+)
src_configure() {
econf \
@@ -57,7 +57,6 @@ src_configure() {
$(use_enable dnstap) \
$(use_with lmdb ) \
$(use_with regex re2) \
- $(use_with remote-logging protobuf) \
$(use_with snmp net-snmp) \
$(use ssl && { echo "--enable-dns-over-tls" && use_with gnutls && use_with !gnutls libssl;} || echo "--without-gnutls --without-libssl") \
$(use_enable systemd) \
diff --git a/net-dns/dnsdist/files/dnsdist-1.6.0-gcc11-missing-include.patch b/net-dns/dnsdist/files/dnsdist-1.6.0-gcc11-missing-include.patch
new file mode 100644
index 000000000000..6e549b2450ee
--- /dev/null
+++ b/net-dns/dnsdist/files/dnsdist-1.6.0-gcc11-missing-include.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/790719
+https://github.com/hhoffstaette/portage/blob/master/net-dns/dnsdist/files/dnsdist-1.6.0-add-missing-include.patch
+
+From: Kees Monshouwer <mind04@monshouwer.org>
+Date: Tue, 11 May 2021 10:27:01 +0200
+Subject: [PATCH] add missing includes (Fedora 34, gcc 11.1 / clang 12)
+
+[HH: reduced to necessary patch for dnsdist]
+---
+ lock.hh | 1 +
+ 1 file changed, 1 insertions(+)
+
+diff --git a/lock.hh b/lock.hh
+index 09299d7979d..0644502f871 100644
+--- a/lock.hh
++++ b/lock.hh
+@@ -20,6 +20,7 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+ #pragma once
++#include <mutex>
+ #include <shared_mutex>
+
+ class ReadWriteLock