summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-11-14 17:54:13 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-11-14 17:54:13 -0500
commitb6493e6c9f7c4f097f1de40b6e954f91ad28f1a0 (patch)
tree26da9455107fbdb49c59d9563776363baa933979 /net-analyzer
parentnet-analyzer/nagios-core: drop 4.4.14 (diff)
downloadgentoo-b6493e6c9f7c4f097f1de40b6e954f91ad28f1a0.tar.gz
gentoo-b6493e6c9f7c4f097f1de40b6e954f91ad28f1a0.tar.bz2
gentoo-b6493e6c9f7c4f097f1de40b6e954f91ad28f1a0.zip
net-analyzer/monitoring-plugins: drop 2.3.5
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/monitoring-plugins/Manifest1
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.3.5.ebuild115
2 files changed, 0 insertions, 116 deletions
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index 7333c93106cf..bf0cd41dd230 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1,2 +1 @@
-DIST monitoring-plugins-2.3.5.tar.gz 2876130 BLAKE2B 7029f6485ef73d29329bcb36e16cbbaa99c57ae20505f554af154b45cc1af6f623dabb35ee5b7f777d728bcae8eafd795f12aabc199cf1f45c9f2335f74b6d41 SHA512 bb04d547584a4aed82bfd605d129b652b45c7356c0610fb1da53a57b2ab889b67afccdd53998e2612ec06571bdc5fc238ef0d378b96e29ec072f657e74eabd55
DIST monitoring-plugins-2.4.0.tar.gz 2746382 BLAKE2B 3e062b9392b4e5885a549ca619eee25f29517e83682e0eb76c8780235b48ab26d79994827c1167e981a993ece3f3f339de61874c912e6fcb17b4cb1af22e97d9 SHA512 7e9aae7768ed9fccbaf377fc54a70374f6a41e8e8ef95cf7440e44fca1080eb23e6b3d737214c96d772eb9a32cdfdbf1b88e0eb35eda0690047d5fe1b485a6b2
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.5.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.5.ebuild
deleted file mode 100644
index b7666ec27696..000000000000
--- a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.5.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic
-
-DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
-HOMEPAGE="https://www.monitoring-plugins.org/"
-SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 sparc x86"
-IUSE="curl gnutls ipv6 ldap mysql dns fping game postgres radius samba snmp ssh +ssl"
-
-# Most of the plugins use automagic dependencies, i.e. the plugin will
-# get built if the binary it uses is installed. For example, check_snmp
-# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
-# installed. End result: most of our runtime dependencies are required
-# at build time as well.
-#
-# REAL_DEPEND contains the dependencies that are actually needed to
-# build. DEPEND contains those plus the automagic dependencies.
-#
-REAL_DEPEND="dev-lang/perl
- curl? (
- dev-libs/uriparser
- net-misc/curl
- )
- ldap? ( net-nds/openldap:= )
- mysql? ( || ( dev-db/mysql-connector-c dev-db/mariadb-connector-c ) )
- postgres? ( dev-db/postgresql:= )
- ssl? (
- !gnutls? (
- dev-libs/openssl:0=
- )
- gnutls? ( net-libs/gnutls )
- )
- radius? ( net-dialup/freeradius-client )"
-
-DEPEND="${REAL_DEPEND}
- dns? ( net-dns/bind-tools )
- game? ( games-util/qstat )
- fping? ( net-analyzer/fping )
- samba? ( net-fs/samba )
- ssh? ( virtual/openssh )
- snmp? ( dev-perl/Net-SNMP
- net-analyzer/net-snmp[-minimal] )"
-
-# Basically everything collides with nagios-plugins.
-RDEPEND="${DEPEND}
- acct-group/nagios
- acct-user/nagios
- !net-analyzer/nagios-plugins"
-
-# At least one test is interactive.
-RESTRICT="test"
-
-# These all come from gnulib and the ./configure checks are working as
-# intended when the functions aren't present. Bugs 921190 and 936891.
-QA_CONFIG_IMPL_DECL_SKIP=(
- MIN
- fpurge
- static_assert
- statvfs64
- alignof
-)
-
-src_configure() {
- append-flags -fno-strict-aliasing
-
- # Use an array to prevent econf from mangling the ping args.
- local myconf=()
-
- if use ssl; then
- myconf+=( $(use_with !gnutls openssl /usr)
- $(use_with gnutls gnutls /usr) )
- else
- myconf+=( --without-openssl )
- myconf+=( --without-gnutls )
- fi
-
- # The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered (bug #468296). But also the path
- # likes to move around on us (bug #883729).
- myconf+=( --with-ping-command="$(command -v ping) -4 -n -U -w %d -c %d %s" )
-
- if use ipv6; then
- myconf+=( --with-ping6-command="$(command -v ping) -6 -n -U -w %d -c %d %s" )
- fi
-
- econf \
- $(use_with curl libcurl) \
- $(use_with curl uriparser) \
- $(use_with mysql) \
- $(use_with ipv6) \
- $(use_with ldap) \
- $(use_with postgres pgsql /usr) \
- $(use_with radius) \
- "${myconf[@]}" \
- --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
- --sysconfdir="/etc/nagios"
-}
-
-DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
- NEWS README REQUIREMENTS SUPPORT THANKS )
-
-pkg_postinst() {
- elog "This ebuild has a number of USE flags that determine what you"
- elog "are able to monitor. Depending on what you want to monitor, some"
- elog "or all of these USE flags need to be set."
- elog
- elog "The plugins are installed in ${EROOT}/usr/$(get_libdir)/nagios/plugins"
-}