summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2024-09-04 06:50:21 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-09-14 11:56:14 +0200
commit59c77856e1d33db452b6c85339581d1a8860d738 (patch)
tree9141173fbcc026a480ec025d9dde1fc041f049f3 /net-analyzer
parentsys-apps/hd-idle: fix systemd dropin file install location (diff)
downloadgentoo-59c77856e1d33db452b6c85339581d1a8860d738.tar.gz
gentoo-59c77856e1d33db452b6c85339581d1a8860d738.tar.bz2
gentoo-59c77856e1d33db452b6c85339581d1a8860d738.zip
net-analyzer/gsa: add 23.3.0
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38419 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/gsa/Manifest2
-rw-r--r--net-analyzer/gsa/gsa-23.3.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/gsa/Manifest b/net-analyzer/gsa/Manifest
index c7dc9a59b4b6..5f782bef01a5 100644
--- a/net-analyzer/gsa/Manifest
+++ b/net-analyzer/gsa/Manifest
@@ -1,2 +1,4 @@
DIST gsa-23.0.0.tar.gz 3605974 BLAKE2B c3797a20427754e0bee32d6e64599f04d1ed474435172efdeb0f3200aaec0d7a7dae0d80c035a762e3b6483f6b629a32e5225737ba521047ef90d564f2d1a036 SHA512 d2dfe12777a8b7610ebc1e7eceb079d38ae1f83085c5a411c115950e55254c82151f77ce16d12342d40b457999f50348a48e66f236a83d145697f68ef9caf993
+DIST gsa-23.3.0.tar.gz 3508732 BLAKE2B 13aa2c7922778c16bc0c2349fb638fbbc96bb9fc2c005310815f0e0b9194b2afb7648cb7efe7f9e9b18b1756224d964c3feba53334d71a9f5f26156cde0a6fde SHA512 d9eaa282ba4babf3f42939f4918b5726fa539e4c4fe64e89ae77cf1887b2f10d5a97f085b168264e7b23c468f194e0c58c565ee86458812065947a4d96c43788
DIST gsa-node-modules-23.0.0.tar.xz 28474728 BLAKE2B f16b863d4a052cfbbc2758d66ca7f7715b2d0a303b916c149e562e9b2f4c2eeb9696447613fa382cc951d72c54758ea285402149f77793c94a0b39f71c39379d SHA512 ab3aedc50f1f9802b2a986a6b2e905b858f42722ef821d9b6d5aac44f113c62142a22292ce90badeb588276391ae64d68de177da727dcf09279105a9b635f4ab
+DIST gsa-node-modules-23.3.0.tar.xz 23747600 BLAKE2B 85a5e30f7c74fa572da26437ac224126cbd657c1b8fc81dddbb0ab037ea0d9ece90cafb2a9678770017e837d1a914ae662cebddcfef9aeeaf9285aaebc1cab8b SHA512 3b03791d775b2318e91db27f49d199dc70d420242751568a663f3cff43cd11610cb3e46664ff8dd295bed974559d815b84421c72643af86ab540d1114c958d80
diff --git a/net-analyzer/gsa/gsa-23.3.0.ebuild b/net-analyzer/gsa/gsa-23.3.0.ebuild
new file mode 100644
index 000000000000..c88164c79281
--- /dev/null
+++ b/net-analyzer/gsa/gsa-23.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_NODE_N="node-modules"
+MY_NODE_D="node_modules"
+MY_NODE_PV="${PV}"
+
+DESCRIPTION="Greenbone Security Assistant"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/gsa"
+SRC_URI="
+ https://github.com/greenbone/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/greenbone/${PN}/releases/download/v${PV}/${PN}-${MY_NODE_N}-${PV}.tar.xz
+"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=net-libs/nodejs-18.0.0[ssl]
+ >=sys-apps/yarn-1.22
+"
+
+MY_NODE_DIR="${S}/${MY_NODE_D}/"
+
+src_prepare() {
+ default
+ # We will use pre-generated npm stuff.
+ mv "${WORKDIR}/${MY_NODE_D}" "${MY_NODE_DIR}" || die "couldn't move node_modules"
+
+ # Make SVGR not traverse the path up to / looking for a
+ # configuration file. Fixes
+ # Error: EACCES: permission denied, open '/.config/svgrrc'
+ # in case a directory /.config exists, see https://bugs.gentoo.org/909731
+ echo "runtimeConfig: false" > .svgrrc.yml || die
+}
+
+src_compile() {
+ # setting correct PATH for finding react-js
+ NODE_ENV=production PATH="${PATH}:${MY_NODE_DIR}/.bin/" \
+ yarn --offline build || die
+}
+
+src_install() {
+ insinto "usr/share/gvm/gsad/web"
+ doins -r build/*
+}