summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-24 11:59:50 +0200
committerDavid Seifert <soap@gentoo.org>2020-10-24 11:59:50 +0200
commit031e54a70563761a40798ebe3ac741cda5fed20e (patch)
treed52f4341e9e3f212a63e6dce79b2878f2954fca9 /net-analyzer
parentacct-user/pcap: Add user for capturing network traffic (diff)
downloadgentoo-031e54a70563761a40798ebe3ac741cda5fed20e.tar.gz
gentoo-031e54a70563761a40798ebe3ac741cda5fed20e.tar.bz2
gentoo-031e54a70563761a40798ebe3ac741cda5fed20e.zip
net-analyzer/wireshark: Port to GLEP 81 'pcap' group
Bug: https://bugs.gentoo.org/314463 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/wireshark-3.2.7-r1.ebuild (renamed from net-analyzer/wireshark/wireshark-3.2.7.ebuild)14
-rw-r--r--net-analyzer/wireshark/wireshark-3.3.0-r1.ebuild (renamed from net-analyzer/wireshark/wireshark-3.3.0.ebuild)14
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild14
3 files changed, 15 insertions, 27 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.2.7.ebuild b/net-analyzer/wireshark/wireshark-3.2.7-r1.ebuild
index 275d063e26e3..7f35aeb71f89 100644
--- a/net-analyzer/wireshark/wireshark-3.2.7.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.2.7-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit fcaps flag-o-matic multilib python-any-r1 qmake-utils user xdg-utils cmake
+inherit fcaps flag-o-matic multilib python-any-r1 qmake-utils xdg-utils cmake
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -22,6 +22,7 @@ IUSE="
S=${WORKDIR}/${P/_/}
CDEPEND="
+ acct-group/pcap
>=dev-libs/glib-2.32:2
>=net-dns/c-ares-1.5
dev-libs/libgcrypt:0
@@ -97,10 +98,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-99999999-ui-needs-wiretap.patch
)
-pkg_setup() {
- enewgroup wireshark
-}
-
src_configure() {
local mycmakeargs
@@ -240,17 +237,16 @@ pkg_postinst() {
xdg_mimeinfo_database_update
# Add group for users allowed to sniff.
- enewgroup wireshark
- chgrp wireshark "${EROOT}"/usr/bin/dumpcap
+ chgrp pcap "${EROOT}"/usr/bin/dumpcap
if use dumpcap && use pcap; then
- fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ fcaps -o 0 -g pcap -m 4710 -M 0710 \
cap_dac_read_search,cap_net_raw,cap_net_admin \
"${EROOT}"/usr/bin/dumpcap
fi
ewarn "NOTE: To capture traffic with wireshark as normal user you have to"
- ewarn "add yourself to the wireshark group. This security measure ensures"
+ ewarn "add yourself to the pcap group. This security measure ensures"
ewarn "that only trusted users are allowed to sniff your traffic."
}
diff --git a/net-analyzer/wireshark/wireshark-3.3.0.ebuild b/net-analyzer/wireshark/wireshark-3.3.0-r1.ebuild
index d2607c117e43..64b826a93c81 100644
--- a/net-analyzer/wireshark/wireshark-3.3.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.3.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit fcaps flag-o-matic multilib python-any-r1 qmake-utils user xdg-utils cmake
+inherit fcaps flag-o-matic multilib python-any-r1 qmake-utils xdg-utils cmake
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -22,6 +22,7 @@ IUSE="
S=${WORKDIR}/${P/_/}
CDEPEND="
+ acct-group/pcap
>=dev-libs/glib-2.32:2
>=net-dns/c-ares-1.5
dev-libs/libgcrypt:0
@@ -94,10 +95,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-99999999-ui-needs-wiretap.patch
)
-pkg_setup() {
- enewgroup wireshark
-}
-
src_configure() {
local mycmakeargs
@@ -239,17 +236,16 @@ pkg_postinst() {
xdg_mimeinfo_database_update
# Add group for users allowed to sniff.
- enewgroup wireshark
- chgrp wireshark "${EROOT}"/usr/bin/dumpcap
+ chgrp pcap "${EROOT}"/usr/bin/dumpcap
if use dumpcap && use pcap; then
- fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ fcaps -o 0 -g pcap -m 4710 -M 0710 \
cap_dac_read_search,cap_net_raw,cap_net_admin \
"${EROOT}"/usr/bin/dumpcap
fi
ewarn "NOTE: To capture traffic with wireshark as normal user you have to"
- ewarn "add yourself to the wireshark group. This security measure ensures"
+ ewarn "add yourself to the pcap group. This security measure ensures"
ewarn "that only trusted users are allowed to sniff your traffic."
}
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 8783f28b0851..ef9604fe2d12 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit fcaps flag-o-matic git-r3 multilib python-any-r1 qmake-utils user xdg-utils cmake
+inherit fcaps flag-o-matic git-r3 multilib python-any-r1 qmake-utils xdg-utils cmake
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -22,6 +22,7 @@ IUSE="
S=${WORKDIR}/${P/_/}
CDEPEND="
+ acct-group/pcap
>=dev-libs/glib-2.32:2
>=net-dns/c-ares-1.5
dev-libs/libgcrypt:0
@@ -93,10 +94,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-99999999-ui-needs-wiretap.patch
)
-pkg_setup() {
- enewgroup wireshark
-}
-
src_configure() {
local mycmakeargs
@@ -238,17 +235,16 @@ pkg_postinst() {
xdg_mimeinfo_database_update
# Add group for users allowed to sniff.
- enewgroup wireshark
- chgrp wireshark "${EROOT}"/usr/bin/dumpcap
+ chgrp pcap "${EROOT}"/usr/bin/dumpcap
if use dumpcap && use pcap; then
- fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ fcaps -o 0 -g pcap -m 4710 -M 0710 \
cap_dac_read_search,cap_net_raw,cap_net_admin \
"${EROOT}"/usr/bin/dumpcap
fi
ewarn "NOTE: To capture traffic with wireshark as normal user you have to"
- ewarn "add yourself to the wireshark group. This security measure ensures"
+ ewarn "add yourself to the pcap group. This security measure ensures"
ewarn "that only trusted users are allowed to sniff your traffic."
}