summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2021-03-18 23:07:23 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-22 15:33:55 +0200
commitcc4c1785e2c3ea574cdf5b0b082e1ba47dfc1d40 (patch)
tree44e2d1b34c0ad4aee135b66ee863973034c66b83 /net-analyzer/ospd-openvas
parentnet-analyzer/ospd: version bump to 20.8.2 (diff)
downloadgentoo-cc4c1785e2c3ea574cdf5b0b082e1ba47dfc1d40.tar.gz
gentoo-cc4c1785e2c3ea574cdf5b0b082e1ba47dfc1d40.tar.bz2
gentoo-cc4c1785e2c3ea574cdf5b0b082e1ba47dfc1d40.zip
net-analyzer/ospd-openvas: version bump to 20.8.1
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/ospd-openvas')
-rw-r--r--net-analyzer/ospd-openvas/Manifest1
-rw-r--r--net-analyzer/ospd-openvas/ospd-openvas-20.8.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/ospd-openvas/Manifest b/net-analyzer/ospd-openvas/Manifest
index 36b0ffc73446..00956885cf41 100644
--- a/net-analyzer/ospd-openvas/Manifest
+++ b/net-analyzer/ospd-openvas/Manifest
@@ -1 +1,2 @@
DIST ospd-openvas-1.0.1.tar.gz 50455 BLAKE2B 06a4cdcc2f51351215fffa5517cb2cae620b9b7ffded738d3c63bda11fa8572fe93e0b5fc1c8c9a1bd27cbea65641b0586c329d1d05a022e1fba79c8782d091c SHA512 bdcdb1a8bc08fc27f1a85846ad944b3764a67c153cd75ffa607f69e0c07f223aa0e0965ee081e2398d4d47fc6faf1fd6fad90e6bc724952a0679de783dd2cc87
+DIST ospd-openvas-20.8.1.tar.gz 86733 BLAKE2B 1f747d7409a9b2cef4ea320cdc3fb8714105498ac798c96bb4be243a000985b881e33b56458d1c97b7a0359d51c95a4f975efa97cd4405b359d5a1e7aeaba9e6 SHA512 fb4ceb0a2306255e59948fe2246f9c66adefb4e68e26d3a8f95366a9ef1cb5581a3b036f6982cdd4c8499a9fb1e6acbe72041144e9ff3a057fc253e0684c0c0f
diff --git a/net-analyzer/ospd-openvas/ospd-openvas-20.8.1.ebuild b/net-analyzer/ospd-openvas/ospd-openvas-20.8.1.ebuild
new file mode 100644
index 000000000000..18cbd96b1442
--- /dev/null
+++ b/net-analyzer/ospd-openvas/ospd-openvas-20.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 systemd
+
+DESCRIPTION="This is an OSP server implementation to allow GVM to remotely control OpenVAS"
+HOMEPAGE="https://github.com/greenbone/ospd-openvas"
+SRC_URI="https://github.com/greenbone/ospd-openvas/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ acct-group/gvm
+ acct-user/gvm
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.7.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.5.3[${PYTHON_USEDEP}]
+ >=net-analyzer/ospd-20.8.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-analyzer/openvas-scanner-20.8.0"
+BDEPEND=""
+
+distutils_enable_tests unittest
+
+python_install() {
+ distutils-r1_python_install
+
+ insinto /etc/openvas
+ doins "${FILESDIR}"/redis.conf.example
+ doins "${FILESDIR}"/ospd.conf
+
+ fowners -R gvm:gvm /etc/openvas
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}