summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-09-09 08:56:41 +0200
committerJeroen Roovers <jer@gentoo.org>2019-09-09 08:58:03 +0200
commit8174e41dd01d980e7ec9f6f2f5dd9d13ed4a4676 (patch)
tree4176d3d0f97f1766e8fb3a3a934ccf7a6a7ef886 /net-analyzer/net-snmp
parentsys-kernel/pf-sources: bump to 5.2-pf8 (diff)
downloadgentoo-8174e41dd01d980e7ec9f6f2f5dd9d13ed4a4676.tar.gz
gentoo-8174e41dd01d980e7ec9f6f2f5dd9d13ed4a4676.tar.bz2
gentoo-8174e41dd01d980e7ec9f6f2f5dd9d13ed4a4676.zip
net-analyzer/net-snmp: Add IUSE=pcap
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Bug: https://bugs.gentoo.org/693854 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/net-snmp')
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.8-pcap.patch41
-rw-r--r--net-analyzer/net-snmp/metadata.xml3
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.8-r3.ebuild205
3 files changed, 248 insertions, 1 deletions
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.8-pcap.patch b/net-analyzer/net-snmp/files/net-snmp-5.8-pcap.patch
new file mode 100644
index 000000000000..43692240acb6
--- /dev/null
+++ b/net-analyzer/net-snmp/files/net-snmp-5.8-pcap.patch
@@ -0,0 +1,41 @@
+--- a/configure.d/config_project_with_enable
++++ b/configure.d/config_project_with_enable
+@@ -1187,6 +1187,11 @@
+ [],
+ [with_bzip2="no"])
+
++AC_ARG_WITH([pcap],
++ [ --with-pcap[=DIR] use libpcap in DIR],
++ [],
++ [with_pcap="no"])
++
+ NETSNMP_ARG_WITH(
+ [mnttab],
+ AS_HELP_STRING(
+--- a/configure.d/config_os_libs2
++++ b/configure.d/config_os_libs2
+@@ -583,14 +590,16 @@
+ ##
+ # libpcap
+ ##
+-NETSNMP_BUILD_PCAP_PROG_TRUE='#'
+-NETSNMP_BUILD_PCAP_PROG_FALSE=''
+-AC_CHECK_LIB([pcap], [pcap_create], [
+- AC_CHECK_HEADERS([pcap/pcap.h], [
+- NETSNMP_BUILD_PCAP_PROG_TRUE=''
+- NETSNMP_BUILD_PCAP_PROG_FALSE='#'
+- ])
+-])
++if test "x$with_pcap" = "xyes" ; then
++ NETSNMP_BUILD_PCAP_PROG_TRUE='#'
++ NETSNMP_BUILD_PCAP_PROG_FALSE=''
++ AC_CHECK_LIB([pcap], [pcap_create], [
++ AC_CHECK_HEADERS([pcap/pcap.h], [
++ NETSNMP_BUILD_PCAP_PROG_TRUE=''
++ NETSNMP_BUILD_PCAP_PROG_FALSE='#'
++ ])
++ ])
++fi
+ AC_SUBST(NETSNMP_BUILD_PCAP_PROG_TRUE)
+ AC_SUBST(NETSNMP_BUILD_PCAP_PROG_FALSE)
+
diff --git a/net-analyzer/net-snmp/metadata.xml b/net-analyzer/net-snmp/metadata.xml
index 95e28946a27a..f3f6819a5361 100644
--- a/net-analyzer/net-snmp/metadata.xml
+++ b/net-analyzer/net-snmp/metadata.xml
@@ -10,10 +10,11 @@
<flag name="kmem">Enable usage of /dev/kmem</flag>
<flag name="mfd-rewrites">Use MFD rewrites of mib modules where available</flag>
<flag name="netlink">Use <pkg>dev-libs/libnl</pkg> to fetch TCP statistics instead of using /proc/net/tcp (Linux only).</flag>
+<flag name="pcap">Install snmppcap which reads from PCAP files and writes to the SNMP transport</flag>
<flag name="pci">Use libpci (from <pkg>sys-apps/pciutils</pkg>) to look up network interface description. This feature is only available on Linux.</flag>
<flag name="rpm">Enable monitoring of <pkg>app-arch/rpm</pkg>. This flag requires the bzip2 and zlib flags to be enabled as well.</flag>
-<flag name="ucd-compat">Build UCD compatibility library. Increases significantly the install size.</flag>
<flag name="smux">Enable support for the legacy smux protocol (superseded by agentx)</flag>
+<flag name="ucd-compat">Build UCD compatibility library. Increases significantly the install size.</flag>
</use>
<upstream>
<remote-id type="sourceforge">net-snmp</remote-id>
diff --git a/net-analyzer/net-snmp/net-snmp-5.8-r3.ebuild b/net-analyzer/net-snmp/net-snmp-5.8-r3.ebuild
new file mode 100644
index 000000000000..ff99cf4ad761
--- /dev/null
+++ b/net-analyzer/net-snmp/net-snmp-5.8-r3.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=yesplz
+DISTUTILS_OPTIONAL=yesplz
+WANT_AUTOMAKE=none
+PATCHSET=3
+GENTOO_DEPEND_ON_PERL=no
+
+inherit autotools distutils-r1 eutils perl-module systemd
+
+DESCRIPTION="Software for generating and retrieving SNMP data"
+HOMEPAGE="http://www.net-snmp.org/"
+SRC_URI="
+ mirror://sourceforge/project/${PN}/${PN}/${PV/_p*/}/${P/_p*/}.tar.gz
+ https://dev.gentoo.org/~jer/${PN}-5.7.3-patches-3.tar.xz
+"
+
+S=${WORKDIR}/${P/_/.}
+
+# GPL-2 for the init scripts
+LICENSE="HPND BSD GPL-2"
+SLOT="0/35"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="
+ X bzip2 doc elf kmem ipv6 libressl lm_sensors mfd-rewrites minimal mysql
+ netlink pcap pci perl python rpm selinux smux ssl tcpd ucd-compat zlib
+"
+
+COMMON_DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ elf? ( dev-libs/elfutils )
+ lm_sensors? ( sys-apps/lm_sensors )
+ mysql? ( dev-db/mysql-connector-c:0= )
+ netlink? ( dev-libs/libnl:3 )
+ pcap? ( net-libs/libpcap )
+ pci? ( sys-apps/pciutils )
+ perl? ( dev-lang/perl:= )
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ rpm? (
+ app-arch/rpm
+ dev-libs/popt
+ )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6d:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ perl? (
+ X? ( dev-perl/Tk )
+ !minimal? ( dev-perl/TermReadKey )
+ )
+ selinux? ( sec-policy/selinux-snmp )
+"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ rpm? ( bzip2 zlib )
+"
+S=${WORKDIR}/${P/_p*/}
+
+RESTRICT=test
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # snmpconf generates config files with proper selinux context
+ use selinux && eapply "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
+
+ eapply "${FILESDIR}"/${PN}-5.7.3-include-limits.patch
+ eapply "${FILESDIR}"/${PN}-5.8-my_bool.patch
+ eapply "${FILESDIR}"/${PN}-5.8-pcap.patch
+ eapply "${FILESDIR}"/${PN}-5.8-tinfo.patch
+
+ mv "${WORKDIR}"/patches/0002-Respect-DESTDIR-for-pythoninstall.patch{,.disabled} || die
+ mv "${WORKDIR}"/patches/0004-Don-t-report-CFLAGS-and-LDFLAGS-in-net-snmp-config.patch{,.disabled} || die
+ eapply "${WORKDIR}"/patches/*.patch
+
+ eapply_user
+
+ eautoconf
+}
+
+src_configure() {
+ # keep this in the same line, configure.ac arguments are passed down to config.h
+ local mibs="host ucd-snmp/dlmod ucd-snmp/diskio ucd-snmp/extensible mibII/mta_sendmail etherlike-mib/dot3StatsTable"
+ use lm_sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
+ use smux && mibs="${mibs} smux"
+
+ # Assume /etc/mtab is not present with a recent baselayout/openrc (bug #565136)
+ use kernel_linux && export ac_cv_ETC_MNTTAB=/etc/mtab
+
+ econf \
+ $(use_enable !ssl internal-md5) \
+ $(use_enable ipv6) \
+ $(use_enable mfd-rewrites) \
+ $(use_enable perl embedded-perl) \
+ $(use_enable ucd-compat ucd-snmp-compatibility) \
+ $(use_with bzip2) \
+ $(use_with elf) \
+ $(use_with kmem kmem-usage) \
+ $(use_with mysql) \
+ $(use_with netlink nl) \
+ $(use_with pcap) \
+ $(use_with pci) \
+ $(use_with perl perl-modules INSTALLDIRS=vendor) \
+ $(use_with python python-modules) \
+ $(use_with rpm) \
+ $(use_with ssl openssl) \
+ $(use_with tcpd libwrap) \
+ $(use_with zlib) \
+ --enable-shared --disable-static \
+ --with-default-snmp-version="3" \
+ --with-install-prefix="${D}" \
+ --with-ldflags="${LDFLAGS}" \
+ --with-logfile="/var/log/net-snmpd.log" \
+ --with-mib-modules="${mibs}" \
+ --with-persistent-directory="/var/lib/net-snmp" \
+ --with-sys-contact="root@Unknown" \
+ --with-sys-location="Unknown"
+}
+
+src_compile() {
+ for target in snmplib agent sedscript all; do
+ emake OTHERLDFLAGS="${LDFLAGS}" ${target}
+ done
+
+ use doc && emake docsdox
+}
+
+src_install () {
+ # bug #317965
+ emake -j1 DESTDIR="${D}" install
+
+ if use perl ; then
+ perl_delete_localpod
+ if ! use X; then
+ rm "${D}"/usr/bin/tkmib || die
+ fi
+ else
+ rm -f \
+ "${D}"/usr/bin/fixproc \
+ "${D}"/usr/bin/ipf-mod.pl \
+ "${D}"/usr/bin/mib2c \
+ "${D}"/usr/bin/net-snmp-cert \
+ "${D}"/usr/bin/snmp-bridge-mib \
+ "${D}"/usr/bin/snmpcheck \
+ "${D}"/usr/bin/snmpconf \
+ "${D}"/usr/bin/tkmib \
+ "${D}"/usr/bin/traptoemail \
+ "${D}"/usr/share/snmp/mib2c.perl.conf \
+ "${D}"/usr/share/snmp/snmp_perl_trapd.pl \
+ || die
+ fi
+
+ dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO
+ newdoc EXAMPLE.conf.def EXAMPLE.conf
+
+ if use doc; then
+ docinto html
+ dodoc -r docs/html/*
+ fi
+
+ keepdir /var/lib/net-snmp
+
+ newinitd "${FILESDIR}"/snmpd.init.2 snmpd
+ newconfd "${FILESDIR}"/snmpd.conf snmpd
+
+ newinitd "${FILESDIR}"/snmptrapd.init.2 snmptrapd
+ newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd
+
+ systemd_dounit "${FILESDIR}"/snmpd.service
+ systemd_dounit "${FILESDIR}"/snmptrapd.service
+
+ insinto /etc/snmp
+ newins "${S}"/EXAMPLE.conf snmpd.conf.example
+
+ # Remove everything not required for an agent.
+ # Keep only the snmpd, snmptrapd, MIBs, headers and libraries.
+ if use minimal; then
+ rm -rf \
+ "${D}"/**/*.pl \
+ "${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,check,conf},fixproc,traptoemail} \
+ "${D}"/usr/share/snmp/*.conf \
+ "${D}"/usr/share/snmp/snmpconf-data \
+ || die
+ fi
+
+ prune_libtool_files
+}