summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nagios-check_linux_bonding
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nagios-check_linux_bonding')
-rw-r--r--net-analyzer/nagios-check_linux_bonding/Manifest2
-rw-r--r--net-analyzer/nagios-check_linux_bonding/metadata.xml9
-rw-r--r--net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild35
-rw-r--r--net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.4.ebuild35
4 files changed, 81 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_linux_bonding/Manifest b/net-analyzer/nagios-check_linux_bonding/Manifest
new file mode 100644
index 000000000000..b64b0c26a9b7
--- /dev/null
+++ b/net-analyzer/nagios-check_linux_bonding/Manifest
@@ -0,0 +1,2 @@
+DIST check_linux_bonding-1.3.2.tar.gz 24540 SHA256 4c10b9c6840d70d736d3d18a95c5173624f97d76b9d107cc77b8cd0075ca9963 SHA512 c00eb7b209d49c8552b1e5e38196890bc4c5bed26d57af8c8b89e750488bd0822c74ab2efa58ba20309cfe6444e5aafd98db14946a5b09e334fb5f9a4fd404e8 WHIRLPOOL 03a4e00b45bbe8ce574f5a0893ad71c80050cd14c141193f360b6f6e4262305349e658d9645fb2daa800561a9b9bf28d12d3a4b3db1988949f14e1f080834446
+DIST check_linux_bonding-1.4.tar.gz 24670 SHA256 67d663740c0c84b7069c805048e7c5a0c50f818d173dba514a8e68c5bbc6b4a1 SHA512 2b1e11007680accd8667ceb8710c7a7448766fd0c5aa3be60a34209f1b25892e7fecc46f9fc5e7cc0d4776f68cc17f8db8d8f2758695c82045a5832e8a4c7e81 WHIRLPOOL 1bcd792469c87d1ca3971fdf342bf7f82d435c1c59c2aef83348bb10e2f14dab2a7ecbb3d2a8788e92ed22e726d8ef79ef838442a73340083de3726341afa1e7
diff --git a/net-analyzer/nagios-check_linux_bonding/metadata.xml b/net-analyzer/nagios-check_linux_bonding/metadata.xml
new file mode 100644
index 000000000000..4128863055b4
--- /dev/null
+++ b/net-analyzer/nagios-check_linux_bonding/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz (ercpe)</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild b/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild
new file mode 100644
index 000000000000..ba928354432d
--- /dev/null
+++ b/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+MY_P=${P/nagios-/}
+
+DESCRIPTION="Nagios plugin to monitor bonding status of network interfaces"
+HOMEPAGE="http://folk.uio.no/trondham/software/check_linux_bonding.html"
+SRC_URI="http://folk.uio.no/trondham/software/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ default
+
+ local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
+ dodir "${nagiosplugindir}"
+ exeinto ${nagiosplugindir}
+ doexe check_linux_bonding
+
+ dodoc CHANGES
+ doman man/check_linux_bonding.8
+}
diff --git a/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.4.ebuild b/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.4.ebuild
new file mode 100644
index 000000000000..ba928354432d
--- /dev/null
+++ b/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+MY_P=${P/nagios-/}
+
+DESCRIPTION="Nagios plugin to monitor bonding status of network interfaces"
+HOMEPAGE="http://folk.uio.no/trondham/software/check_linux_bonding.html"
+SRC_URI="http://folk.uio.no/trondham/software/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ default
+
+ local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
+ dodir "${nagiosplugindir}"
+ exeinto ${nagiosplugindir}
+ doexe check_linux_bonding
+
+ dodoc CHANGES
+ doman man/check_linux_bonding.8
+}