summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-08-31 10:37:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-08-31 10:37:02 -0500
commit62d6f88b901f3f76160b31aed7c1edf58e9209d0 (patch)
tree0f3cf801fd7bb888d1af3505f47bb5c2dd285746 /net-analyzer/icinga2
parentsys-kernel/vanilla-sources: add 5.15.64, drop 5.15.63 (diff)
downloadgentoo-62d6f88b901f3f76160b31aed7c1edf58e9209d0.tar.gz
gentoo-62d6f88b901f3f76160b31aed7c1edf58e9209d0.tar.bz2
gentoo-62d6f88b901f3f76160b31aed7c1edf58e9209d0.zip
net-analyzer/icinga2: drop 2.13.3
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-analyzer/icinga2')
-rw-r--r--net-analyzer/icinga2/Manifest1
-rw-r--r--net-analyzer/icinga2/icinga2-2.13.3.ebuild145
2 files changed, 0 insertions, 146 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index f72c456fee3e..e61495e85394 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1,3 +1,2 @@
-DIST icinga2-2.13.3.tar.gz 7529976 BLAKE2B f661919b0a7b420eba663d6cb01f2223c15b2be7f4ad649e1e09b7b4068d1122d63c6baac490ff3a0bd808066b759138748e70de364eea4d89f560168a448c72 SHA512 818eb565c6d46bfb538d70b9e33bb7424ab6fb98289da9eb947ec1f36b7e3b0e3869db789acd565b5e5b3d8b4819fe991000f4df362e28686dd9e3394cec3743
DIST icinga2-2.13.4.tar.gz 9662432 BLAKE2B fdae71d081a646b2f70d768b43c56602221d585997a1fca96d2f6c30c27eb6344a443a1d12981c94542fdb77443b40be3c4ec87796a82bfcab1b53fe6b46e0ec SHA512 454eb03587c66de2697d0d604fab37ae4ce243653357cd3295998ab9b58287acefc27876e06e530b8bd6bb4d96c1289a1f05ef25f0b19573123a0cf1d99b5cfb
DIST icinga2-2.13.5.tar.gz 9663739 BLAKE2B 9ce884cfd66eb6ab9a6977c8e751465bbec30605c0b62302850e2533ea5b3bfa003074807ad21a4338d37c41fac59454eb65edbca7ab7c4897ecd74a4d41ff1f SHA512 7ac8970292795b8675a8fdc25ee0a68c6fe506d7413fe9c3c61e90ca159bdf01af43343de2217cbb4b5e446139c97e8b115b4dcd10b8ef68e884a07b80669f5d
diff --git a/net-analyzer/icinga2/icinga2-2.13.3.ebuild b/net-analyzer/icinga2/icinga2-2.13.3.ebuild
deleted file mode 100644
index 39584c5c24c3..000000000000
--- a/net-analyzer/icinga2/icinga2-2.13.3.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
-fi
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="https://icinga.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="console jumbo-build lto mail mariadb minimal +mysql nano-syntax +plugins postgres systemd +vim-syntax"
-
-# Add accounts to DEPEND because of fowners in src_install
-DEPEND="
- dev-libs/openssl:0=
- >=dev-libs/boost-1.66.0:=[context]
- console? ( dev-libs/libedit )
- mariadb? ( dev-db/mariadb-connector-c:= )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:= )
- dev-libs/yajl:=
- acct-user/icinga
- acct-group/icinga
- acct-group/icingacmd"
-BDEPEND="
- sys-devel/bison
- >=sys-devel/flex-2.5.35"
-RDEPEND="
- ${DEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- mail? ( virtual/mailx )
- acct-group/nagios"
-
-REQUIRED_USE="!minimal? ( || ( mariadb mysql postgres ) )"
-
-src_configure() {
- local mycmakeargs=(
- -DICINGA2_UNITY_BUILD=$(usex jumbo-build)
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DICINGA2_RUNDIR=/run
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=ON
- -DUSE_SYSTEMD=$(usex systemd)
- -DLOGROTATE_HAS_SU=ON
- -DICINGA2_LTO_BUILD=$(usex lto)
- )
- # default to off if minimal, allow the flags to be set otherwise
- if use minimal; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- -DICINGA2_WITH_PGSQL=OFF
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=$(usex postgres)
- -DICINGA2_WITH_MYSQL=$(usex mysql yes $(usex mariadb))
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- newinitd "${FILESDIR}"/icinga2.initd-3 icinga2
-
- if use mysql || use mariadb; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- fi
- if use postgres; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}/run" || die "failed to remove /run"
- rm -r "${D}/var/cache" || die "failed to remove /var/cache"
-
- fowners -R icinga:icinga /etc/icinga2
- fperms 0750 /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners -R icinga:icingacmd /var/lib/icinga2/api
- fowners -R icinga:icingacmd /var/lib/icinga2/certificate-requests
- fowners -R icinga:icingacmd /var/lib/icinga2/certs
- fowners icinga:icinga /var/spool/icinga2
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- if [[ "${PV}" != 9999 ]]; then
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${PV}" -gt "${v}"; then
- elog "DB IDO schema upgrade may be required."
- elog "https://www.icinga.com/docs/icinga2/latest/doc/16-upgrading-icinga-2/"
- fi
- done
- fi
-}