summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-17 14:44:53 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-17 15:31:55 +0200
commite04335421b5c33d683efd019f3e28a1c94573dfa (patch)
tree5d3fde85c8b56c39cf901ff4dc9a41738c4f337c /media-video
parentnet-libs/gnome-online-accounts: Drop old (diff)
downloadgentoo-e04335421b5c33d683efd019f3e28a1c94573dfa.tar.gz
gentoo-e04335421b5c33d683efd019f3e28a1c94573dfa.tar.bz2
gentoo-e04335421b5c33d683efd019f3e28a1c94573dfa.zip
media-video/subtitleeditor: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitleeditor/Manifest1
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-video/subtitleeditor/Manifest b/media-video/subtitleeditor/Manifest
index c511af270283..11acc1a6819a 100644
--- a/media-video/subtitleeditor/Manifest
+++ b/media-video/subtitleeditor/Manifest
@@ -1 +1,2 @@
DIST subtitleeditor-0.52.1.tar.gz 1680875 SHA256 5b3e5fc1f12bcf0d4bcf5014249b6832181bd3b513ac04ee665ec979441412d5 SHA512 a9a7ee78abadf660fe645e36ed69b87131320e04373554adb48dc33df8f36605ed74da3822fe0281b2b75d6f82daddd062b2ae9a12aed44673195fba43adfd4f WHIRLPOOL def330a098b9227cf6db8a74c67d2cd7db724b65f586e22ebf1b08de6de6321849fdeecfe5fd6c0132a814d45d84087b406a05aec7463c04a4355530c3d09c44
+DIST subtitleeditor-0.53.0.tar.gz 1778388 SHA256 8fac7430fb552438d075ef3809d4a0f04a764d4dd0723a3ef18b2b695fecf920 SHA512 8787831947785885befb50221869169eda73489851389e72f34edac7a9c2c59d05ba69e86d4d2d5b3a13b2678377ee2520c110ffa472b718884dd2e711603b8b WHIRLPOOL cfd7bfd2324fe10dadd6e8c7c60487072d15dee3c6f0a57358abee4e5f92c945ba95efb036516ecadc0beebf52380b835cb35ae8af389110597ab5305a979639
diff --git a/media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild
new file mode 100644
index 000000000000..4e8c956d2e9b
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit flag-o-matic gnome2 versionator
+
+DESCRIPTION="GTK+3 subtitle editing tool"
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+# opengl would mix gtk+:2 and :3 which is not possible
+
+RDEPEND="
+ >=app-text/enchant-1.4
+ app-text/iso-codes
+ >=dev-cpp/cairomm-1.12
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-cpp/gstreamermm-1.0:1.0
+ >=dev-cpp/libxmlpp-2.40:2.6
+ dev-libs/glib:2
+ >=dev-libs/libsigc++-2.6:2
+ media-libs/gst-plugins-base:1.0[X,pango]
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-libs/gtk+:3
+ virtual/libintl
+"
+# opengl? (
+# >=dev-cpp/gtkglextmm-1.2.0-r2:1.0
+# virtual/opengl )
+# X needed for video output and pango needed for text overlay
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
+ use debug && append-cxxflags -DDEBUG
+
+ gnome2_src_configure \
+ --disable-debug \
+ --disable-gl \
+ $(use_enable nls)
+# $(use_enable opengl gl)
+}