summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-05 06:25:38 +0100
committerSam James <sam@gentoo.org>2022-07-05 06:27:03 +0100
commit8aa3f1714ef74b678a3aee5530708be7b1e32462 (patch)
tree4b6ec0df6c87c1e22c3640ebd0f050b103fe6aa8 /media-video
parentdev-ruby/flog: add 4.6.6 (diff)
downloadgentoo-8aa3f1714ef74b678a3aee5530708be7b1e32462.tar.gz
gentoo-8aa3f1714ef74b678a3aee5530708be7b1e32462.tar.bz2
gentoo-8aa3f1714ef74b678a3aee5530708be7b1e32462.zip
media-video/wireplumber: only apply alsa/bluez patch in ~arch
I think ed5e534a1cd4ae88036e99bcb81420e28f824768 was the result of a mis-rebase/issue vs when the PR was filed and then later merged -- at the time, wireplumber 0.4.10-r3 wasn't stable, but now it is. The intention was to have it with the new PW changes which are now only in ~arch. Revbump in ~arch for that new patch (the config one) and also revbump stable to drop the patch to ensure anyone who emerged it within an unfortunate window has a consistent experience. Fixes: ed5e534a1cd4ae88036e99bcb81420e28f824768 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/wireplumber/wireplumber-0.4.10-r4.ebuild126
-rw-r--r--media-video/wireplumber/wireplumber-0.4.10-r5.ebuild (renamed from media-video/wireplumber/wireplumber-0.4.10-r3.ebuild)2
2 files changed, 127 insertions, 1 deletions
diff --git a/media-video/wireplumber/wireplumber-0.4.10-r4.ebuild b/media-video/wireplumber/wireplumber-0.4.10-r4.ebuild
new file mode 100644
index 000000000000..ac75996452f4
--- /dev/null
+++ b/media-video/wireplumber/wireplumber-0.4.10-r4.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{3,4} )
+
+inherit lua-single meson systemd
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/pipewire/${PN}.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/pipewire/${PN}/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~sparc x86"
+fi
+
+DESCRIPTION="Replacement for pipewire-media-session"
+HOMEPAGE="https://gitlab.freedesktop.org/pipewire/wireplumber"
+
+LICENSE="MIT"
+SLOT="0/0.4"
+IUSE="elogind system-service systemd test"
+
+REQUIRED_USE="
+ ${LUA_REQUIRED_USE}
+ ?? ( elogind systemd )
+ system-service? ( systemd )
+"
+
+RESTRICT="!test? ( test )"
+
+# introspection? ( dev-libs/gobject-introspection ) is valid but likely only used for doc building
+BDEPEND="
+ dev-libs/glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ sys-devel/gettext
+"
+
+DEPEND="
+ ${LUA_DEPS}
+ >=dev-libs/glib-2.62
+ >=media-video/pipewire-0.3.48:=
+ virtual/libc
+ virtual/libintl
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+# Any dev-lua/* deps get declared like this inside RDEPEND:
+# $(lua_gen_cond_dep '
+# dev-lua/<NAME>[${LUA_USEDEP}]
+# ')
+RDEPEND="${DEPEND}
+ system-service? (
+ acct-user/pipewire
+ acct-group/pipewire
+ )
+"
+
+DOCS=( {NEWS,README}.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-config-fix-enabled-property-to-default-to-true-when.patch
+ "${FILESDIR}"/${P}-m-lua-scripting-allow-converting-GValue-holding-NUL.patch
+ "${FILESDIR}"/${P}-alsa.lua-fix-device-name-deduplication-when-reserva.patch
+ "${FILESDIR}"/${P}-m-default-nodes-don-t-check-if-all-device-nodes-are.patch
+ "${FILESDIR}"/${P}-m-lua-scripting-fix-object-refcounting.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddoc=disabled # Ebuild not wired up yet (Sphinx, Doxygen?)
+ -Dintrospection=disabled # Only used for Sphinx doc generation
+ -Dsystem-lua=true # We always unbundle everything we can
+ -Dsystem-lua-version=$(ver_cut 1-2 $(lua_get_version))
+ $(meson_feature elogind)
+ $(meson_feature systemd)
+ $(meson_use system-service systemd-system-service)
+ $(meson_use systemd systemd-user-service)
+ -Dsystemd-system-unit-dir=$(systemd_get_systemunitdir)
+ -Dsystemd-user-unit-dir=$(systemd_get_userunitdir)
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # We copy the default config, so that Gentoo tools can pick up on any
+ # updates and /etc does not end up with stale overrides.
+ # If a reflinking CoW filesystem is used (e.g. Btrfs), then the files
+ # will not actually get stored twice until modified.
+ insinto /etc
+ doins -r "${ED}"/usr/share/wireplumber
+}
+
+pkg_postinst() {
+ if systemd_is_booted ; then
+ ewarn "pipewire-media-session.service is no longer installed. You must switch"
+ ewarn "to wireplumber.service user unit before your next logout/reboot:"
+ ewarn "systemctl --user disable pipewire-media-session.service"
+ ewarn "systemctl --user --force enable wireplumber.service"
+ else
+ ewarn "Switch to WirePlumber will happen the next time gentoo-pipewire-launcher"
+ ewarn "is started (a replacement for directly calling pipewire binary)."
+ ewarn
+ ewarn "Please ensure that ${EROOT}/etc/pipewire/pipewire.conf either does not exist"
+ ewarn "or, if it does exist, that any reference to"
+ ewarn "${EROOT}/usr/bin/pipewire-media-session is commented out (begins with a #)."
+ fi
+ if use system-service; then
+ ewarn
+ ewarn "WARNING: you have enabled the system-service USE flag, which installs"
+ ewarn "the system-wide systemd units that enable WirePlumber to run as a system"
+ ewarn "service. This is more than likely NOT what you want. You are strongly"
+ ewarn "advised not to enable this mode and instead stick with systemd user"
+ ewarn "units. The default configuration files will likely not work out of"
+ ewarn "box, and you are on your own with configuration."
+ ewarn
+ fi
+}
diff --git a/media-video/wireplumber/wireplumber-0.4.10-r3.ebuild b/media-video/wireplumber/wireplumber-0.4.10-r5.ebuild
index 82772e332ad8..80e5772a49b4 100644
--- a/media-video/wireplumber/wireplumber-0.4.10-r3.ebuild
+++ b/media-video/wireplumber/wireplumber-0.4.10-r5.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://gitlab.freedesktop.org/pipewire/${PN}/-/archive/${PV}/${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~sparc x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="Replacement for pipewire-media-session"