summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2023-02-18 21:03:00 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2023-02-18 21:03:00 +0100
commit378e5fab6143f180d3fd2631508fcee92cc94b68 (patch)
treecd08f29d45745281b303dfcac1b57c0b41ac9b2d /media-video
parentsys-process/daemontools: honour AR, CC (diff)
downloadgentoo-378e5fab6143f180d3fd2631508fcee92cc94b68.tar.gz
gentoo-378e5fab6143f180d3fd2631508fcee92cc94b68.tar.bz2
gentoo-378e5fab6143f180d3fd2631508fcee92cc94b68.zip
media-video/vidcutter: snapshot version bump with py3.11; EAPI bump; PEP517.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vidcutter/Manifest1
-rw-r--r--media-video/vidcutter/vidcutter-6.0.5.1_p20230201.ebuild45
-rw-r--r--media-video/vidcutter/vidcutter-9999.ebuild5
3 files changed, 49 insertions, 2 deletions
diff --git a/media-video/vidcutter/Manifest b/media-video/vidcutter/Manifest
index 8c9575a6b569..1ed1f8585d99 100644
--- a/media-video/vidcutter/Manifest
+++ b/media-video/vidcutter/Manifest
@@ -1,2 +1,3 @@
DIST vidcutter-6.0.5.1-libmpv-api2.patch 2327139 BLAKE2B c2665e2c501a19db86a25145da39e6990843fb11a7bdf3170ec7e268e23a23abb21cd8d4b459a4c862ffc27756106d81e7d9b5d58bf3417fd787c03528eba770 SHA512 063908bf939c03952d623cc0ae7ea301d4605660a548e3088f6c901f3d98cf13a5e49180414c8a1c05931d9c4ca2a251858951676632768ff30954a6df7a4e4a
DIST vidcutter-6.0.5.1.tar.gz 9909274 BLAKE2B 063c20f6ae0565b0f3a160b5ee298aae05b2ee1876cd4c73d9f37578a9e86a872353c3e2b7b1b6302db3d5a876139bfb19d50bf7cb4dd18e6e1d1a1ca3587fbd SHA512 f2ea2a86d9eaa3c6593e785daad6869c151baa1add529c9edaf2282f7acad762fbb29804790aece5e4fcd89e9e9bc77f61d1f0b68a1b1f3ecf58951ee8f200e9
+DIST vidcutter-6.0.5.1_p20230201.tar.gz 9858362 BLAKE2B da10506810f93f5635a364d35f293a2c587455ee5c29cf28c0636b7441e330e6ab70385c22d9da914a22c71fed9f6d13688bcac9106d4430e5820fdd2b377d28 SHA512 1b355db77f4e78ade6c0553441d9b60739209fde74db6d9f0be3613e31f99806c94f33bf40912a43106dfc77bde09a54768d5786e06116af3dae2f9851823041
diff --git a/media-video/vidcutter/vidcutter-6.0.5.1_p20230201.ebuild b/media-video/vidcutter/vidcutter-6.0.5.1_p20230201.ebuild
new file mode 100644
index 000000000000..bd4fdbba2f04
--- /dev/null
+++ b/media-video/vidcutter/vidcutter-6.0.5.1_p20230201.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg
+
+MY_COMMIT="8f01c76f0ec727fa336cb2cb6a645a58e3a29e64"
+DESCRIPTION="FFmpeg-based simple video cutter & joiner with a modern PyQt5 GUI"
+HOMEPAGE="http://vidcutter.ozmartians.com https://github.com/ozmartian/vidcutter"
+
+if [[ ${PV} == 9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ozmartian/vidcutter"
+else
+ SRC_URI="https://github.com/ozmartian/${PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=media-video/mpv-0.25:=[libmpv]
+"
+RDEPEND="${DEPEND}
+ >=dev-python/PyQt5-5.7[dbus,multimedia,widgets,${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-video/ffmpeg[X,encode]
+ media-video/mediainfo"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
+}
diff --git a/media-video/vidcutter/vidcutter-9999.ebuild b/media-video/vidcutter/vidcutter-9999.ebuild
index 2f533e76bc5f..a8ca07fe5865 100644
--- a/media-video/vidcutter/vidcutter-9999.ebuild
+++ b/media-video/vidcutter/vidcutter-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 xdg