summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-19 09:20:44 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-21 23:56:05 +0200
commitaeef2c27041a599b08534bb601bcf095b2e0e3a0 (patch)
tree605a5c7463cb855d7f776072ea930635ecd219cf /media-video/m2vrequantizer
parentdev-python/seaborn: version bump. (diff)
downloadgentoo-aeef2c27041a599b08534bb601bcf095b2e0e3a0.tar.gz
gentoo-aeef2c27041a599b08534bb601bcf095b2e0e3a0.tar.bz2
gentoo-aeef2c27041a599b08534bb601bcf095b2e0e3a0.zip
media-video/m2vrequantizer: EAPI 7 bump and improve ebuild.
Closes: https://github.com/gentoo/gentoo/pull/9283
Diffstat (limited to 'media-video/m2vrequantizer')
-rw-r--r--media-video/m2vrequantizer/m2vrequantizer-0.0.2_pre20060306-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-video/m2vrequantizer/m2vrequantizer-0.0.2_pre20060306-r1.ebuild b/media-video/m2vrequantizer/m2vrequantizer-0.0.2_pre20060306-r1.ebuild
new file mode 100644
index 000000000000..e7d607277c1c
--- /dev/null
+++ b/media-video/m2vrequantizer/m2vrequantizer-0.0.2_pre20060306-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${PN/m2vr/M2VR}-20060306"
+
+DESCRIPTION="Tool to requantize mpeg2 videos"
+HOMEPAGE="http://www.metakine.com/products/dvdremaster/modules.html"
+SRC_URI="mirror://vdrfiles/requant/${MY_P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+S="${WORKDIR}/M2VRequantiser"
+
+src_prepare() {
+ default
+ sed -i "s:#elif defined(__i386__):#elif defined(__i386__) || defined(__amd64__):" main.c || die
+}
+
+src_compile() {
+ $(tc-getCC) -c ${CFLAGS} main.c -o requant.o || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} requant.o -o requant -lm || die
+}
+
+src_install() {
+ dobin requant
+}