summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/gaupol
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/gaupol')
-rw-r--r--media-video/gaupol/Manifest2
-rw-r--r--media-video/gaupol/gaupol-0.19.2-r1.ebuild60
-rw-r--r--media-video/gaupol/gaupol-0.28.2.ebuild50
-rw-r--r--media-video/gaupol/metadata.xml6
4 files changed, 118 insertions, 0 deletions
diff --git a/media-video/gaupol/Manifest b/media-video/gaupol/Manifest
new file mode 100644
index 000000000000..461237cfb771
--- /dev/null
+++ b/media-video/gaupol/Manifest
@@ -0,0 +1,2 @@
+DIST gaupol-0.19.2.tar.gz 651580 SHA256 4e30fb7f4ff328561243450367be0c1ec80878f7107cac8eda6db9877a90aff4 SHA512 5d95c4f2610e7305f91c29701f4d2edfbd69f782a296c5152515d3391cb58ab83c34412c67f0bbbdf6159198bb90da1f43652b483efc0320dec5870f077e9884 WHIRLPOOL 272e7c9fc4c8e41b2ef4832c6de161e83303894055d3f9c8e91dc58a1fe3c5170186f1de3f7bd36bbdbf8fbacefff170f9d52a714acdd85596be15dfa804265d
+DIST gaupol-0.28.2.tar.xz 495248 SHA256 d02d81ace0d41dbf7707251cd86e28876acf86dd82c36e34371d38cd21212d4c SHA512 e3b47e35fe7825a105870e6e691ee85f168d7f171eb2da2775b88a099069b0593a9878fe9ec8f47fa824d8aa5a18f28278c78731538a64d900401b13d38ae7d8 WHIRLPOOL 36abedf44872c904520663d3c845cfcfcdc8a438ef1b8ac09910dc13cac8a88a22dcdcaee44ebd05ad4f504df67694dafc45b44aa0da632296d864a56a1cf9fb
diff --git a/media-video/gaupol/gaupol-0.19.2-r1.ebuild b/media-video/gaupol/gaupol-0.19.2-r1.ebuild
new file mode 100644
index 000000000000..95344e1cd379
--- /dev/null
+++ b/media-video/gaupol/gaupol-0.19.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime gnome2-utils versionator
+
+MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Gaupol is a subtitle editor for text-based subtitles"
+HOMEPAGE="http://home.gna.org/gaupol"
+SRC_URI="http://download.gna.org/${PN}/${MAJOR_MINOR_VERSION}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="spell"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.16[${PYTHON_USEDEP}]
+ spell? (
+ app-text/iso-codes
+ >=dev-python/pyenchant-1.4[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext"
+
+DOCS=( AUTHORS ChangeLog CREDITS NEWS TODO README )
+
+src_compile() {
+ addpredict /root/.gconf
+ addpredict /root/.gconfd
+ distutils-r1_src_compile
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ elog "Previewing support needs MPlayer or VLC."
+
+ if use spell; then
+ elog "Additionally, spell-checking requires a dictionary, any of"
+ elog "Aspell/Pspell, Ispell, MySpell, Uspell, Hspell or AppleSpell."
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-video/gaupol/gaupol-0.28.2.ebuild b/media-video/gaupol/gaupol-0.28.2.ebuild
new file mode 100644
index 000000000000..3bca8584fbee
--- /dev/null
+++ b/media-video/gaupol/gaupol-0.28.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1 fdo-mime gnome2-utils versionator
+
+MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
+
+DESCRIPTION="A subtitle editor for text-based subtitles"
+HOMEPAGE="http://home.gna.org/gaupol"
+SRC_URI="http://download.gna.org/${PN}/${MAJOR_MINOR_VERSION}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="spell"
+
+RDEPEND="app-text/iso-codes
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ spell? (
+ >=dev-python/pyenchant-1.4[${PYTHON_USEDEP}]
+ app-text/gtkspell:3
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext"
+
+DOCS=( AUTHORS.md NEWS.md TODO.md README.md README.aeidon.md )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ elog "Previewing support needs MPlayer or VLC."
+
+ if use spell; then
+ elog "Additionally, spell-checking requires a dictionary, any of"
+ elog "Aspell/Pspell, Ispell, MySpell, Uspell, Hspell or AppleSpell."
+ fi
+}
diff --git a/media-video/gaupol/metadata.xml b/media-video/gaupol/metadata.xml
new file mode 100644
index 000000000000..862cfbc4e837
--- /dev/null
+++ b/media-video/gaupol/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <herd>python</herd>
+</pkgmetadata>