summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-20 03:22:03 +0000
committerSam James <sam@gentoo.org>2023-01-20 03:54:11 +0000
commite5a6e89d164f5bd4688094b206170d0a37dbfa75 (patch)
tree71e7a2366e53dec6c537a5bb765ff6bd56eb4b7d /media-sound
parentmedia-libs/netpbm: add tiff subslot operator (diff)
downloadgentoo-e5a6e89d164f5bd4688094b206170d0a37dbfa75.tar.gz
gentoo-e5a6e89d164f5bd4688094b206170d0a37dbfa75.tar.bz2
gentoo-e5a6e89d164f5bd4688094b206170d0a37dbfa75.zip
media-sound/spek: add 0.8.5
Closes: https://bugs.gentoo.org/834397 Closes: https://bugs.gentoo.org/631702 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spek/Manifest1
-rw-r--r--media-sound/spek/spek-0.8.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/spek/Manifest b/media-sound/spek/Manifest
index 60f47392b50a..9818c2bad9f4 100644
--- a/media-sound/spek/Manifest
+++ b/media-sound/spek/Manifest
@@ -1,2 +1,3 @@
DIST spek-0.8.3.tar.gz 1349573 BLAKE2B ce783c319741c43f27462caf9dcd27e71f4c8fbc9d3a3d2ac0b977189cca4cf8ed14f258958bbf59532c4cae97562fa20819222ae68567e9e607f243a2777000 SHA512 a4b54746316d295574bc963e650728b23b3730ee6bcc8d78b043a5678baac70a0e859870120de2b0e6a17059e9e3757075f4691e2abde98c083afc393e93e17c
DIST spek-0.8.4.tar.xz 430096 BLAKE2B 4b3a512f0a8e74650161c9ed7ef0e054325d9f42743362180d970854fccc99cf20fcf329643ffbd0e84a5ee0aff746d2fc2750b91f300e29243ce1194b1b0d9d SHA512 08e39d4c0c7732feec159a8ff29550a62bab37a01325589787e027a027c50ee926f4cd9e0971061bf4e0b53a590b842c6586b4173e09cc9b27dd3b5668dc2d8b
+DIST spek-0.8.5.tar.xz 430464 BLAKE2B 54c977cc38f8162ec7fe45fe9eca023a9bdd2c1b42c0ad80dcf07c15ab93b416f58b499a3e8a9b9bb2ed16143deb899ce1c4fed2eba6b0e78eeab8b23a3326e7 SHA512 25f72c9372b142183ab34c47f1d7d6e62b9316d94b31aacff5d3ca007be030f4848a385be1bbb98f285aba010804fd429a7e099e597c30861347f5b8ed50d5b1
diff --git a/media-sound/spek/spek-0.8.5.ebuild b/media-sound/spek/spek-0.8.5.ebuild
new file mode 100644
index 000000000000..fa0bd400115a
--- /dev/null
+++ b/media-sound/spek/spek-0.8.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit wxwidgets xdg
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://spek.cc/"
+SRC_URI="https://github.com/alexkay/spek/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=media-video/ffmpeg-5:=
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.4-disable-updates.patch
+)
+
+src_configure() {
+ setup-wxwidgets unicode
+ default
+}