summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-18 20:24:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-18 20:24:45 +0100
commitd2ef19be60fd2d18def5d6aa51dd5d185783179e (patch)
tree47f4e24bbc683c399a4db085564131439c10b23d /media-sound
parentapp-emulation/docker: Version bump to 17.09.1 (diff)
downloadgentoo-d2ef19be60fd2d18def5d6aa51dd5d185783179e.tar.gz
gentoo-d2ef19be60fd2d18def5d6aa51dd5d185783179e.tar.bz2
gentoo-d2ef19be60fd2d18def5d6aa51dd5d185783179e.zip
media-sound/clementine: Fix DEPENDs, LINGUAS
Disable tests dir if USE=!test. Bug: https://bugs.gentoo.org/641586 Closes: https://bugs.gentoo.org/641524 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20171113.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/media-sound/clementine/clementine-1.3.1_p20171113.ebuild b/media-sound/clementine/clementine-1.3.1_p20171113.ebuild
index 8522d19cb629..5208d152f2ce 100644
--- a/media-sound/clementine/clementine-1.3.1_p20171113.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20171113.ebuild
@@ -74,8 +74,7 @@ DEPEND="${COMMON_DEPEND}
>=dev-cpp/gtest-1.8.0
dev-cpp/gmock
)
- dev-libs/boost:=
- dev-qt/qttest:4
+ dev-libs/boost
sys-devel/gettext
virtual/pkgconfig
box? ( dev-cpp/sparsehash )
@@ -84,8 +83,12 @@ DEPEND="${COMMON_DEPEND}
pulseaudio? ( media-sound/pulseaudio )
seafile? ( dev-cpp/sparsehash )
skydrive? ( dev-cpp/sparsehash )
- test? ( gnome-base/gsettings-desktop-schemas )
+ test? (
+ dev-qt/qttest:4
+ gnome-base/gsettings-desktop-schemas
+ )
"
+
DOCS=( Changelog README.md )
PATCHES=( "${FILESDIR}"/${PN}-1.3-fix-tokenizer.patch )
@@ -98,6 +101,9 @@ src_prepare() {
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
tests/CMakeLists.txt || die
+
+ use test || cmake_comment_add_subdirectory tests
+ rm -r 3rdparty/{gmock,google-breakpad,libprojectm,taglib} || die
}
src_configure() {
@@ -114,10 +120,9 @@ src_configure() {
-DENABLE_GIO=ON
-DENABLE_SPOTIFY_BLOB=OFF
-DUSE_BUILTIN_TAGLIB=OFF
- -DUSE_SYSTEM_GMOCK=ON
-DUSE_SYSTEM_PROJECTM=ON
-DBUNDLE_PROJECTM_PRESETS=OFF
- -DLINGUAS=$(l10n_get_locales)
+ -DLINGUAS="$(l10n_get_locales)"
-DENABLE_BOX="$(usex box)"
-DENABLE_AUDIOCD="$(usex cdda)"
-DENABLE_DBUS="$(usex dbus)"
@@ -136,6 +141,7 @@ src_configure() {
)
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
+ use test && mycmakeargs+=( -DUSE_SYSTEM_GMOCK=ON )
cmake-utils_src_configure
}