summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-26 05:48:00 +0000
committerSam James <sam@gentoo.org>2024-11-26 06:05:24 +0000
commit6903d98e459c3089700ad60a89b10671802679e8 (patch)
tree3c89d7bf6f46405c383eeae4f5f024c5fe056ee3 /media-sound
parentapp-arch/patool: drop 2.3.0 (diff)
downloadgentoo-6903d98e459c3089700ad60a89b10671802679e8.tar.gz
gentoo-6903d98e459c3089700ad60a89b10671802679e8.tar.bz2
gentoo-6903d98e459c3089700ad60a89b10671802679e8.zip
media-sound/mpg123-base: add 1.32.9
There's a bunch of configure option changes upstream which I want to double check with Igor, but I'm pretty sure that we discussed them all before and it doesn't change the approach we took wrt the mpg123-base and mpg123-output-plugins split for bug #915858 -- so I've not changed any of that in the ebuild. Bug: https://bugs.gentoo.org/915858 Bug: https://bugs.gentoo.org/942561 Closes: https://bugs.gentoo.org/943699 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpg123-base/Manifest1
-rw-r--r--media-sound/mpg123-base/mpg123-base-1.32.9.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/media-sound/mpg123-base/Manifest b/media-sound/mpg123-base/Manifest
index 1baeb7a33f18..4327db810573 100644
--- a/media-sound/mpg123-base/Manifest
+++ b/media-sound/mpg123-base/Manifest
@@ -1 +1,2 @@
DIST mpg123-1.32.3.tar.bz2 1111054 BLAKE2B 67f889403c2bb639d675ec5ebea5a19c4b7174971d62bdd8d940ad659e6b0c06dada38422fc9d71b878917aa89e305ec48c8faa78d65d507cd6a0c9a79951359 SHA512 946c1073b6eebfd65333ec543df1caeea25864479e9c8e153fb53d8b636cc756d8d81947f7b5cbedbbfb1ea664d3fb27562ed36e7726d95e80591bd2ad622afc
+DIST mpg123-1.32.9.tar.bz2 1118388 BLAKE2B 370012300ca6cd26daf48cc067692e94c2c37c7549f6581d64e8f7cc9f08c720518ed6aaa10b3c2194ce2ae85afa5564a65dcf7129c6789f90d24be395ff1397 SHA512 dccb640b0845061811cb41bf145587e7093556d686d49a748232b079659b46284b6cc40db42d14febceac11277c58edf2b69d1b4c46c223829a3d15478e2e26c
diff --git a/media-sound/mpg123-base/mpg123-base-1.32.9.ebuild b/media-sound/mpg123-base/mpg123-base-1.32.9.ebuild
new file mode 100644
index 000000000000..2f1267b7dc35
--- /dev/null
+++ b/media-sound/mpg123-base/mpg123-base-1.32.9.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="mpg123"
+MY_P="${MY_PN}-${PV}"
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="https://www.mpg123.org/"
+SRC_URI="https://downloads.sourceforge.net/${MY_PN}/${MY_P}.tar.bz2"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+# Note: build system prefers libsdl2 > libsdl. We could in theory add both
+# but it's tricky when it comes to handling switching between them properly.
+# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
+RDEPEND="
+ !<media-sound/mpg123-1.32.3-r100
+ !media-libs/libmpg123
+ dev-libs/libltdl:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-build/libtool
+ virtual/pkgconfig
+"
+IDEPEND="app-eselect/eselect-mpg123"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=
+ local _cpu=generic_fpu
+
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+
+ append-lfs-flags
+
+ if $(multilib_is_native_abi) ; then
+ local flag
+ for flag in coreaudio pulseaudio jack alsa oss sdl portaudio nas ; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ fi
+ done
+ fi
+
+ use cpu_flags_ppc_altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext
+ # bug #164504
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=(
+ --with-optimization=0
+ --with-audio=dummy
+ --with-default-audio="${_audio} dummy"
+ --with-cpu=${_cpu}
+ --enable-network
+ $(use_enable ipv6)
+ --enable-int-quality=$(usex int-quality)
+ )
+
+ multilib_is_native_abi || myconf+=( --disable-modules )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123} || die
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}